Cannot change default program for *.txt anymore

The checkbox "Always use the selected program to open this kind of file" is grayed out.
It does not help to open Windows Explorer "as administrator".

Clicking on *.txt file will now open in "cmd"!
Need to restore this..

The checkbox "Always use the selected program to open this kind of file" is grayed out.
Ron DokkensirAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try changing it in Control Panel, Default Programs. Use the Associate submenu.

Does this work?
1
ThommyCommented:
You have to change below registry key:
HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command


This is how you can do it:

Type regedit in RUN dialog box

Go to HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command

On right side change value of "Default" key exactly as below:
%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1
1
ThommyCommented:
You can make it greyed-out again by adding " %2" or any other number from 2-9 to the key value
"%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1"
1
Uttam KumarTech Support ExpertCommented:
Backup registry key before editing. For me what worked was deleting the file type key in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts for which the option got greyed out, you can use .txt if happening only for this.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ron DokkensirAuthor Commented:
Nice!
Deleted..
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.txt ->UserChoice
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.