Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 77
  • Last Modified:

I am seeing no-cache http header on every page served by my IIS 8.5 server (Windows 2012 R2)

I have a web site hosted on Server2012 R2 and every page served has an HTTP Response header of "no-cache". I have set the "Common http response headers" in IIS to expire after 7 days and added a "Cache-Control max-age = 604800" NV pair to the http response headers, but I still see "no-cache" on every page.
Any clues ?
0
Phil Catterall
Asked:
Phil Catterall
  • 2
  • 2
2 Solutions
 
Dr. KlahnPrincipal Software EngineerCommented:
There are apparently some issues with this going back to IIS 7 according to various commenters.

Have you looked at these resources already?

http://stackoverflow.com/questions/4204582/output-caching-still-adding-cache-controlno-cache-even-when-it-is-disabled

https://support.microsoft.com/en-us/kb/247404
0
 
Dan McFaddenSystems EngineerCommented:
There is a chance that the response headers are being set in code.  Can you post a screen shot of your HTTP Response Header config for your site?

I would search thru a few files in the web site and check for something like the following:

<%response.CacheControl="no-cache"%>

Open in new window


Reference Link:  http://www.w3schools.com/asp/prop_cachecontrol.asp

Dan
0
 
Dan McFaddenSystems EngineerCommented:
Any additional info for this question?

Dan
0
 
Dr. KlahnPrincipal Software EngineerCommented:
EE email requested stale question closure.  Two solutions proposed, no response.  Worth keeping in the archives for future reference.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now