[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 112
  • Last Modified:

Cygwin VIM in WIndows 2007: Unable to copy text to Windows

I am pretty sure I had this setup without any heroic efforts. Seems I just highlighted text and pressed enter and the text in VIM went to the copy buffer. Now at a new work place so I'm trying to get all my tools back and this isn't working any more. Any thoughts?
0
amigan_99
Asked:
amigan_99
  • 5
  • 4
1 Solution
 
serialbandCommented:
You probably set the Command Prompt Defaults to "Quick Edit Mode."  It's been a long while since I've installed Cygwin, but I seem to recall that it was associated with the Command Prompt Settings.

When it's not in "Quick Edit Mode," you'll need to right click to select the Mark command.  You should be able to click on the top left corner, select Defaults, then check the "Quick Edit Mode" Box.
0
 
amigan_99Network EngineerAuthor Commented:
Good guess. When you said that I was hopeful as this is a new laptop and perhaps QuickEdit had not been chosen for CMD prompts. Unfortunately - it was already checked and cygwin is still no allowing paste into VIM open document.
0
 
Duncan RoeSoftware DeveloperCommented:
Are you running VIM in a CMD window or in a native cygwin mintty?
In a mintty you copy by highlighting, as in an xterm.
If a CMD window lets you highlight by dragging, you have QuickEdit turned on (which is what you want). Enter will then Copy, but so will right-click. So you can use right-click both to copy and paste.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
amigan_99Network EngineerAuthor Commented:
In the screen shot you can see the window I'm referring to. I launch cygwin and vim say foo.txt and enter some text. I can highlight that text. But if I go to say notepad and press ctrl-v - the expected pasting of that text does not occur. Same is true if I highlight and hit enter then go to notepad and ctrl-v (or rclick paste).

Now if I exit VIM in cygwin and just type whatever in the bash shell - copy and paste between cygwin and windows acts as expected. I just highlight in cygwin and then that's in my win copy buffer. Something about VIM in cygwin is mucking up the copy process.
ScrnGrab11-161013-11.04.jpg
0
 
Duncan RoeSoftware DeveloperCommented:
I just tried  copy by highlighting from vim to a mintty, and it WFFM
0
 
Duncan RoeSoftware DeveloperCommented:
I just tried ^V in Notepad (started from CMD) and that worked as well. Do you really have Windows 2007 on a new laptop?
ee.png
0
 
amigan_99Network EngineerAuthor Commented:
Windows 7 on a T430 Thinkpad. Perhaps I should reinstall cygwin. This will be a third time. The first time I installed it came with no VIM. The second time I selected three or four different VIM options in the installer. Perhaps one of those is gumming up the works. Do you know the specific option to choose to get good VIM? or perhaps there another editor that would work as well?
0
 
Duncan RoeSoftware DeveloperCommented:
Very odd. I have Windows 7 and no problems. I installed VIM this morning: ran the installer and typed vim into the search box and selected it from among the Editors category.
There are hardly any Cygwin questions on EE because the mailing list is so good. I suggest you subscribe and ask your question there.
0
 
amigan_99Network EngineerAuthor Commented:
OK - I'll try a reinstall and if that doesn't do it I'll reach out to the mailing list. Thanks much for the time and thought.
0
 
Duncan RoeSoftware DeveloperCommented:
My pleasure
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now