• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 144
  • Last Modified:

remote logins for proxy table in sybase

Dears, kindly note I have created an external login and a remote login as following: sp_addremotelogin remoteserver,locallogin1, remotelogin1 sp_addexternallogin remoteserver,locallogin1, remotelogin1

and I log in by user locallogin1 to the localserver to the database localdb and try to create proxy table from remotedb1 on remoteserver but still get the login failed error, any body know why??

kindly note there is localuser1 aliased to locallogin1 , i.e there is no user 'locallogin1' (direct mapping) on the database localdb where I try to create proxy table, rather there is a user localuser1 is alias to locallogin1, is this related to the problem??

please advice
0
suzn cas
Asked:
suzn cas
  • 3
  • 2
1 Solution
 
Joe WoodhousePrincipal ConsultantCommented:
Have you added remoteserver using sp_addserver?

Does the server name you used in sp_addserver exactly the same as its name in your local interfaces file?

Is the password for locallogin1 on localserver the same as the password for remotelogin1 on remoteserver?

Can you log in directly to remoteserver using remotelogin1 and that password?

I don't believe the alias will matter because if your error is a login error, you haven't gotten as far as databases, users or aliases yet. Can you share the exact error message?
0
 
suzn casDBAAuthor Commented:
Dear Joe, Thanks alot,
Is the password for locallogin1 on localserver the same as the password for remotelogin1 on remoteserver?
NO, it is not.they are different logins name with different passwords.

for example: the locallogin1 = suzn with password = 123 , and the remotelogin1 = rami with password 'rami',
is this the case?? so what can I do, create a local login at remote server with = (login name = suzn with password = 123), then may locallogin at local server (uzn with password = 123) with him ??????
0
 
Joe WoodhousePrincipal ConsultantCommented:
Passwords are your problem. When you use sp_addremotelogin and sp_addexternlogin, you can specify what the remote password is. It looks like you haven't done that. It's simple, add it as one more parameter:

exec sp_addexternlogin [remoteserver], [locallogin], [remotelogin], [remotepassword]
go

Open in new window

1
 
suzn casDBAAuthor Commented:
Dear Joe, Thanks in advance.
I add remote password to the sp_addexternallogin and every thing is well.
Thank you
0
 
suzn casDBAAuthor Commented:
when the passwords for local login and remote login are not tha same , we should add remotepassword as:

exec sp_addexternlogin [remoteserver], [locallogin], [remotelogin], [remotepassword]

Thanks  Joe Woodhouse
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now