Active directory GPO inheritance

Dear All,

I have a GPO on domain level for setting default home page ,which is applied to all OU's,i want to change the default home page for some OU's, even after i apply a new GPO on the child OU the default domian level GPO i getting applied,how do i stop this and apply only the GPO which is applied on child OU.

Who is Participating?
Adam BrownConnect With a Mentor Sr Solutions ArchitectCommented:
Unless the GPO that is linked to the domain is configured as "Enforced", GPOs linked directly to OUs will take precedence by default. Setting a GPO to be "Enforced" causes it to take precedence on the OUs it is linked to and all child OUs. Using the Enforced setting is not a best practice because it complicates troubleshooting efforts. Right click the GPO that is linked to the Domain and make sure the Enforced option doesn't have a Checkmark next to it. If it does, click on it to remove the checkmark so it isn't enforced anymore. Once you do that, your GPOs linked to the child OUs you want should then take precedence. Enforced GPOs will *always* win when the settings in other GPOs are different. You can't keep this from happening by changing link order in GPMC, so make sure that Domain level GPO setting the home page isn't enforced.
*** Hopeleonie ***Connect With a Mentor IT ManagerCommented:
Did you change the Link Order in the OU? Otherwise the GPO on domain level will win.
SysguysAuthor Commented:
link order means ? i didn't get you.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Muhammad MullaCommented:
You will need to check the precedence of the GPOs under the inheritance tab in GPMC if they are at the same level.

Normally GPOs apply in this order: site, domain, OU and child OU. As a result, your GPO applied at the child OU level should overwrite the settings. From what you are saying, however, it sounds like this isn't happening.

Have you tried to enforce the GPO at the child OU?

If you don't want any of the settings from the default domain GPO, you could block inheritance from GPMC.

This might give you a better idea:
SysguysAuthor Commented:
There are lot of other GPO's that are needed which are also applied on domian level ,if i block inheritance i will not get the other policies.
Muhammad MullaCommented:
There are two ways you can go about this.

1. Block inheritance and link all the GPOs that are required directly to the child OU. Take care of the precedence order.

2. Enforce the GPO containing your default homepage settings.

Try both methods on a test OU with a test user and see which one works better for you.
*** Hopeleonie ***Connect With a Mentor IT ManagerCommented:
@Muhammad Mulla
Blocking and Enforcing is not best practice.

have a look under Group Policy Inheritance:
SysguysAuthor Commented:
thanks for helping i blocked inheritance and applied all the required GPO's except the home page and create a new GPO for the home page
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.