Solved

Cannot load device driver, error code 39

Posted on 2016-10-12
25
102 Views
Last Modified: 2016-11-22
This is really strange - I have this Dell Optiplex 7010 which one day stopped recognizing external disk drives. SD cards, USB Flash drives, external HDDs. I'm getting error code 39, and after researching it the only thing that came close was something about high filters and low filters. Well, that didn't apply to my scenario (no fix). So I resorted to the one thing that gave me hope was a 2 months old Acronis Image. The restore went fine, but surprisingly, the problem reoccurred right away (at the first login). At this point nothing makes sense.

USB works fine with other devices (printer, Wifi adapter).
USB works fine when booting to the Acronis recovery CD.
Dell diagnostics show no problems.
Updated all drivers, Dell drivers, the BIOS is current.

What now????

Thank you.
0
Comment
Question by:btm02sf
  • 11
  • 9
  • 3
  • +1
25 Comments
 
LVL 4

Expert Comment

by:jmac44
ID: 41841091
Are the ports turned on in the BIOS? It sounds like you did a restore from USB drive but maybe at that level the ports work. I know with with my Optilex's you can turn the front, 2 gang and 4 gang on and off independently in the BIOS.

Also: You might try downgrading the BIOS http://www.dell.com/support/article/us/en/04/SLN125793 and http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=V89FN. See if that helps.
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41841161
Yes, they are On. When I insert the device, it beeps as if it is installing, and then the drivers fail to load. And, at the onset of this problem I had an older BIOS - and only upgraded in an attempt to fix it. In addition, the Acronis boot environment has no issue reading external drives. I will nevertheless verify right now - everything is enabled.

Thanks
0
 
LVL 91

Expert Comment

by:nobus
ID: 41841409
open device manager -usb devices and when you connect any device, check it's power consulmption in it's properties
it looks like the data llines are working, but not the power line
check also in energy settings if they are not turned off to save power (and if they are, choose the other setting, reboot and test - even if they were on)
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41842421
Note that allow the computer to turn off the device to conserve power has been unchecked for quite a while so it can't be a factor.

Also note that throughout these iterations I've compared what I see to the same options on another Dell system which works. There were no discrepancies other than in the final result (code 39).

So, of the 3 Generic Hubs, and two USB Root Hubs (plus other controllers which don't have the "power" tab). Of the first 3 Generic,  one shows 8 ports, 0mA consumption. Another shows 4 ports, with two taken by the keyboard and mouse (70 - 100mA). The Third shows 6 ports, one Generic Usb hub (4 ports 0mA, and one used for 500mA - I'm guessing that this is the internal universal card reader. When I plug in an external Western Digital HDD, it is this hub which recognizes the drive also at 500 mA, and then drops to 3 available ports. Note that I do get the message that this device could perform faster if plugged into an USB 3.0 port. When plugging into the USB 3.0 port on the front of the computer - there is no telling which USB powers it. It does however appear in either configuration (USB 2 or 3) as a device in the "other devices" category: WD SES Device USB device" - with driver not installed, code 28 this time (missed that the first time).

I then did try with a small USB SD card reader and an eye-fi mobi SD card.  When I click to see the results of the device driver installation I get USB Mass storage device: ready to use, and right after: "multople card reader USB device: Failed. AND the Generic USB Hub (third from above) shows the device at 100mA (note that it also says "total power available - 500mA per port).

I understand how the one thing that may explain why we're still malfunctioning after reimaging is an underlying hardware problem - is that what we're driving at?
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41842494
Building on what you're alluding to, I've disconnected the internal multi-card reader (hooked up to int usb). The only port that had 500mA on is now available, AND to begin with, device manager is showing no malfunction of any kind. I'm now going to plug in the external WD drive and then the external SD card with the USB reader...

First test - failed just like before. 500mA for the WD, but disk drives shows the WD my passport as malfunctioning as well as WD SES Device under "other devices".
Second test - failed as well. Multiple Card reader USB Device is showing as code 39 under disk drives. I then tried other ports, in the front, then the back.

It won't mount in the lower row of USB 3 (2 ports) and 2.0 (another 2 ports). It will mount (but code 39) in the top 2 USB 2.0 ports (that's when the third usb controller shows again 100mA).
Strangely, the WD DOES mount (failing with code 39) when plugged into any of the 4 ports on the back, lower. Not clear which 3.0 USB hub feeds power to it, but it showed under the FIRST USB 2.0 hub at 500mA.

HOWEVER: now all of a sudden the SD card DOES show in the lower row of ports (2.0 and 3.0) at 100mA for the USB 2.0 hub. Was I simply not waiting long enough the first time around????? I did, longer than 30 seconds I'm sure. Fine!!! - Turning off (completely) then turning computer back on, then testing with just the SD card in the lower row of ports on the back. I followed the same exact steps as the first time. After one minute, nothing in the first USB 2.0 port (lower row). Have I not waited long enough for the computer to "start"???? It's been 5-6 minutes now on a fairly decent box. Refreshing - nothing. Unplugging, back into the same port, waiting 30 seconds... One minute... Nothing. Computer is quiet (it finished doing what it was doing after starting up). Unplugging, going to the remaining ports.... Well, it showed now in USB 3.0 #2... All, except for port #1 lower - until I ejected the SD card and reinserted it. ... Note that I removed the USB adapter (with the SD card in it), reinserted and it's not showing again in port #1 only. BIZARRE!!!!!  

Well now... I'm not sure that we can weed through this entire set of symptoms as they may relate to different issues on this system (which I must stress again, had no apparent problems until 3 weeks ago).

Next, I'll look for a spare drive and reinstall Windows 7.
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41842545
The new Windows 7 - without any of the Dell drivers installed (e.g. SM Bus controller, USB Controller), the system DOES recognize both the WD and the SD card.

Note that the same devices show under "other devices" while disk drives show the WD and Multiple card reader loading normally, which leads me to believe that we could ignore "other devices" for the purposes of troubleshooting this issue.

I'm going to find and install the Dell Hardware drivers (all of them) next.
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41842593
Now that all of the Dell device drivers have been installed - and it's all working normally - still. Now installing Windows updates (all). That will take a while. Next - Antivirus (Kaspersky Endpoint) and business software. Will keep you posted. If you have any suggestions or warnings, please let me know.

I can't explain why is it that my Acronis was able to image the system in June when obviously this same exact WD HDD was recognized, then we went for 3 months with no issues and then all of a sudden the backup was also faulty. Any chance that we simply didn't notice what happened at the time of the backup (some form of Windows corruption)? Chances of that are slim to none - though I will triple-check.

One more thing I may have not mentioned. I did try to "uninstall" then let windows reinstall the HDD drivers for what it's worth.

Thanks,
0
 
LVL 91

Expert Comment

by:nobus
ID: 41843091
what model is this WD drive?  does it have it's own power?  if not just use a POWERED usb hub to connect it to
remember that USB 2 delivers Max 5Vat 0.5A = 2.5 W
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41844353
I'll have to get back to you on that, specifically. It's a WD Passport, 2 Tb without external power, but to restate, it worked fine before, and after installing Windows on a spare drive, it works fine now. That pretty much rules out a hardware issue, wouldn't you think?
0
 
LVL 91

Expert Comment

by:nobus
ID: 41844673
>>   It's a WD Passport, 2 Tb without external power, but to restate, it worked fine before   <<it may work - but it's working "onthe edge" - look at it's power consumption

>>  That pretty much rules out a hardware issue, wouldn't you think?   <<   where did i mention a hardware problem?  software can cause more power consumption too

and if the disk is getting older, it can draw more energy, especially during startup
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41853058
The drive is fine, most likely, and there's the SD card, and any other disk style device that I might plug in. On the reinstalled OS (different HDD, brand new Windows 7 with all of the updates current), it is working fine. At this point, I'm debating whether there's anything else I could try that it's worth putting the old drive in.

And I'm still at a loss explaining how could a 2 months old Acronis backup have the same issue if it is software?

Thanks.
0
 
LVL 91

Expert Comment

by:nobus
ID: 41853298
without knowing the real problem - that's impossible to tell
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 4

Expert Comment

by:jmac44
ID: 41854469
Take a look at the capacitors on the motherboard. Make sure they're all level on the top or slightly concave. If you see any that are slightly bulging or rounded, it could be the problem. Sometimes an intermittent faulty capacitor will cause problems. Also replace the BIOS battery even if you have gotten no warning that it's low.
0
 
LVL 91

Expert Comment

by:nobus
ID: 41854869
did you check the power it takes?
or did you connect it on anothe rpc to see if it works fine?
you can use a powered usb 2 hub, or an usb 3 one
0
 

Expert Comment

by:Zahier Adams
ID: 41869239
Hi
It is a old usb 2.0 as western digitals came out long back it would be needing a external adapter as it originally powers up with a adapter because when wd was released we never had atx power supplies which consist of 24pins.you can get a 12v adapter then set it to 0.5 or 1amp
The WD came out with ide an the new ones are sata so it kinda depends as into how old that hard drive is if it was a 16pin power supple it would be needing the adapter an a 2.0 usb cable an set the adapter on the lowest voltage which is 0.5amp if all else fails unplug the external an plug it direct as a second hard drive in the box then that one you can set as a slave drive to access whatever is reauired on the harddrive
 Thanks
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41869564
Thanks for the suggestions. I looked at all of the capacitors I could see - they appear to be all fine. I'll get the battery replaced ASAP - just didn't get to it yet.

I don't think it's a matter of power draw. Even the most basic of USB flash cards or an SD card (the adapter is plugged into the internal USB and draws 500mA no matter what's plugged into it. (Also recall that I tested with this 19 in one card reader disconnected from the internal USB.

The WD is fairly new - 2Tb I got in Fry's less than a year ago, and it's USB 3.0.

But more damning is that, after reinstalling Windows to a different HDD, the new environment is experiencing no issues, even after using for a few days, installing updates, applications, etc.  I can't imagine a hardware issue at this point, as all of the devices I've plugged in (including those I tested with all along) are now working just fine.

Thank you!!!!!!
0
 
LVL 91

Expert Comment

by:nobus
ID: 41869645
>>the adapter is plugged into the internal USB and draws 500mA no matter what's plugged into it  <<   that's weird - can you test it on another system - to be sure?
0
 

Expert Comment

by:Zahier Adams
ID: 41870483
There is always the slim possibility that the Code 39 error you're seeing in Device Manager was caused by some fluke with Device Manager or your BIOS. If that's true, a simple reboot might fix the Code 39. Did you install a device or make a change in Device Manager just before you noticed the Code 39? If so, there's a good chance that the change you made caused the Code 39 error.Undo the change, restart your PC, and then check for the Code 39 error again
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41875632
Zahier, thank you - what you're saying makes sense, and I already tried all of that. No changes when this occurred for the first time, but I think I mentioned that I restored an Acronis Image to a moment in time when everything was normal.

Otherwise, I think the focus on the SD card reader may not be warranted, as I had it disconnected and nothing improved, and now with the fresh Win 7 installation it IS connected, draws the same amount yet everything is normal.
0
 

Expert Comment

by:Zahier Adams
ID: 41875645
thanks for informing us:)
0
 
LVL 91

Expert Comment

by:nobus
ID: 41875899
how old was the "old" install?  it may have been corrupted through the years, and you fixed it with a fresh OS

i reinstall my OS every 1-2 years
0
 
LVL 1

Author Comment

by:btm02sf
ID: 41878006
Well, the "old" install was in fact old - perhaps 4 years I would think... Yes, a new install will often address a number of accumulated issues and corruption, but this system was not easy to configure (lots of apps, registered software, etc.), hence the reason why I avoided it (I still have the old drive). In the end I simply found it interesting to try and fix just from the science' point of view as it would be wise that I cut my losses. The only real downside is that I thought I had that image and had all of my bases covered, but sadly that was not the case. Strange.
0
 
LVL 91

Accepted Solution

by:
nobus earned 500 total points
ID: 41878203
agreed - best take an image evry year or so, and store it together with the old -  of course on another disk
0
 
LVL 1

Author Closing Comment

by:btm02sf
ID: 41879180
Will follow up if there's any new development. Many thanks to all who pitched in.
0
 
LVL 91

Expert Comment

by:nobus
ID: 41879968
ok - happy you got it running
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now