Solved

Access 2003 freezing up on Terminal Server 2008 R2

Posted on 2016-10-12
8
30 Views
Last Modified: 2016-10-22
Situation: Access 2003 MDE front end application running in a multi-user terminal server 2008 environment accessing back-end SQL Server 2008 DB. RDP sessions initiated from workstations inside the network result in the Access application window turning white and becoming unresponsive after any interaction with the Access UI. Sessions initiated from outside the network still work normally - using the same terminal server and the same application.

I tried a bare-bones Access session using the native interface on a single ODBC linked table with the same results - a table SELECT statement returned the expected data but when I attempted to interact with the datagrid Access froze.

The event log provided very little: The program MSACCESS.EXE version 11.0.8321.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.

Question: What are some likely candidates that may cause this sort of behavior? Access itself still seems to be working with the remotely initiated sessions and it is at least displaying returned data before freezing up on the locally initiated sessions. Can the RDP protocol itself be causing the problem? How about graphics drivers on the terminal server?

I can try to supply additional information if needed.

Thanks
0
Comment
Question by:kkamm
  • 4
  • 3
8 Comments
 
LVL 13

Expert Comment

by:John Tsioumpris
ID: 41841365
How about a session with mdb...to get a better info of what is going on...
Also have you restarted Terminal server...?
0
 
LVL 57
ID: 41841758
<<inside the network result in the Access application window turning white and becoming unresponsive after any interaction with the Access UI. Sessions initiated from outside the network still work normally - using the same terminal server and the same application.>>

  Just to be clear on the problem; are the inside users also doing a RDP session?  or do they have the apps installed on their station and are just hitting SQL?

 A white screen BTW in of itself means nothing other than you should wait.   When Access executes a query against SQL, it does so synchronously and will stop processing until it gets a response.   That means screen paints might not even occur and you'll get a white screen.

 If the users are just hitting SQL, then it would indicated that you have issues with your SQL protocol's and/or network internally.

Jim.
0
 
LVL 1

Author Comment

by:kkamm
ID: 41841910
John- Rebooted last night to no avail.   I tried a new MDB with a single ODBC link (same DSN as affected app) to one table in the DB. It pulled the data but froze as soon as I tried to interact with Access.

Jim- RDP for both internal and external conx. Internal users connect both with a local application installed on fixed workstations and via RDP for special cases (laptops not joined to the domain). We were looking at our AV solution (Symantec Endpoint) to see if it was interfering and added some exceptions but it didn't change anything.

There were a few Windows updates that occurred since the application last worked  so we are going to uninstall the updates to see if that helps. .NET 4.5 was also installed so we are going to roll that back as well.

I am leaning in the direction that it is a network issue and not an Access issue.
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 57

Assisted Solution

by:Jim Dettman (Microsoft MVP/ EE MVE)
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 41842060
<<I am leaning in the direction that it is a network issue and not an Access issue.>>

 First thing I would check is the protocols SQL has loaded for communications and their sequence (TCPIP, Shared Memory, Named Pipes, etc), vs what the work station has.  If they are not in the same sequence, slowdowns getting a connection to SQL server can occur.

 This is in SQL configuration manager.

 Also, make sure that ODBC connection pooling has not been turned off (this is in ODBC admin applet).

Anti-virus is a good thought and it's simple enough to check (just turn it off for a bit), but usually that's on open of a DB and not a problem after it's running.

 After that, it's a network issue of some type.  If the App works fine for TS users, then it's not Access or the APP.

Jim.
0
 
LVL 57
ID: 41842070
One other thing: I'd do a spot check of the event logs on one of the stations and the SQL Server box.   See if there are any errors related to SQL, networking, or security.

You can get some weird stuff just with clocks being off if your using trusted connections with SQL.

Jim.
0
 
LVL 1

Author Comment

by:kkamm
ID: 41842300
Jim,

Thanks. I'll check each of those items.

On a lark, I tried using the Remote Desktop Client app from the Windows store instead of mstsc.exe and the freezing stopped.  It may end up being part of the solution but it doesn't explain why the default mstsc.exe client freezes so I am looking at this as a workaround to buy time to check the items you have listed.
0
 
LVL 1

Accepted Solution

by:
kkamm earned 0 total points
ID: 41847400
After installing the newest version (v893) of Microsoft Remote Desktop on the affected machines we managed through a heavy shift without an application freeze. The common denominator was they were all running Windows 10. Even though I don't have a specific reason why mstsc.exe started behaving like this I have no reason to return to it as the newer client is faster and scales better.
0
 
LVL 1

Author Closing Comment

by:kkamm
ID: 41855088
Changing the RDP client solved the immediate problem but I will be using the assisted solution to troubleshoot further.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I'll explain how to setup a Plex Media Server (https://plex.tv/) on a Redhat (Centos) 7 based NAS with screenshots to help those looking for assistance.  What is Plex? If you aren't familiar with Plex, it’s a DLNA media serv…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
In Microsoft Access, learn different ways of passing a string value within a string argument. Also learn what a “Type Mis-match” error is about.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question