Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 54
  • Last Modified:

Setting file associations with group policy preferences doesn't seem to work

For users logged into remote desktop (terminal services) on windows server 2008 R2, when they open a .xml file, I need it to open in a web browser instead of notepad.  I've followed the steps from https://technet.microsoft.com/en-us/library/cc754587(v=ws.11).aspx .  However, I can't seem to get it to work.   I've attached some screenshots showing my settings.  Any help would be appreciated.  Thanks.
gp1.JPG
gp2.JPG
0
davidrobertbristow
Asked:
davidrobertbristow
  • 6
  • 5
  • 2
1 Solution
 
Evan CutlerVolunteer Chief Information OfficerCommented:
Since  you pushed it via registry setting, have you tried rebooting your machines?
0
 
davidrobertbristowAuthor Commented:
Yes, I rebooted.
0
 
Evan CutlerVolunteer Chief Information OfficerCommented:
Check your WMI Filters.
Make sure they are covering all of the systems, needing upgrades.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
davidrobertbristowAuthor Commented:
I also tried doing this at the user profile level.  User Configuration -> Preferences -> Control Panel Settings -> Folder Options -> New -> Open With then specified the settings show in the screenshot.
gp3.JPG
0
 
yo_beeDirector of ITCommented:
Where is this GPO located in relations to the Users OU?
If the GPO for Remote Desktop Server is out of the hierarchy of the User's location then the GPO will never apply to the Users.

would you be able to post a screenshot of your GPMC and the locations of the users location in relation to OU's?
GPO1
0
 
davidrobertbristowAuthor Commented:
I created a new GPO rather than using an existing one.  I then applied the policy at the domain level.  It is working now.  Thank you for pointing me in the right direction.
0
 
yo_beeDirector of ITCommented:
That will apply to your entire domain. If you want to have it just apply to your users when logging on to the terminal server you need to leverage loopback or you might be able to use Item Level Targeting to filter only terminal server names.
The LOOPBACK method might be the better course of action here.
0
 
davidrobertbristowAuthor Commented:
Thanks.  I decided that I would like it to apply to the entire domain.
0
 
yo_beeDirector of ITCommented:
Then that makes it really simple.

BTW was the Remoter Server GPO out of the scope of the user's OU hierarchy ?
0
 
davidrobertbristowAuthor Commented:
I hope that I'm answering your question correctly .....  The windows user policy includes the domain as well as the OU for the remote desktop servers.
0
 
yo_beeDirector of ITCommented:
If you did not have any block inheritance (the OU's with blue badges) and it was nested below higher OU's that the GPO applies to than it should have applied.
0
 
davidrobertbristowAuthor Commented:
When I look at the OU that the policy belongs to (remote desktop servers), the policy is 4th on the list but above the windows user policy.  I've attached a screenshot.  Again, I'm a novice at Group Policies and so I hope that I've answered your questions correctly.
GP5.JPG
0
 
yo_beeDirector of ITCommented:
That is what applies to the OU, but does not illustrate where the Users OU resides in relations to the OU that has the GPO's you posted in img.

The image that posted is what I am interested in.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 6
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now