Solved

Laptops acquire wrong DCHP, DNS and Gateway address for Wireless

Posted on 2016-10-14
14
91 Views
Last Modified: 2016-11-04
Our company is on a 192.168.14.x private network. Our DNS/DHCP server is at 192.168.14.5 and the default gateway is at 192.168.14.1 In the past week, random computers on our network have been getting the incorrect DNS server of 192.168.14.235. This address is the Cisco phone system.

When a computer has the incorrect DNS server, they have no connectivity to the Internet. We tried resolving the problem by running ipconfig /release and /renew, and ipconfig /flushdns; we also tried a winsock reset, None of these things resolved the issue.  We tried assigning a static address, which worked, but when we removed the static if failed back to the 14.235 phone system address again.

The computer is running Win10 Pro X64. The weird part of this is that the PHone system does not have any wireless conbnection and the problem oly affects the wireless; the wired connection works properly

Incidentially, there have been no configuration changes to any networking equipment or to the phone system this year and this problem 'suddenly' popped up last week.

Does anyone have any idea why this is happening and how to resolve it?
0
Comment
Question by:LostInWindows
  • 4
  • 4
  • 3
  • +2
14 Comments
 
LVL 92

Expert Comment

by:John Hurst
ID: 41843498
Take one problem laptop and try the following:

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Does this solve the issue?  If so, TCP/IP Reset and DNS Flush is very easy to do on the others.
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 41843567
Hi,
chances are that computers are connected on the phone which is connected to the switch, and they get the dhcp parameters which should be peculiar to phones.
If this is the case, the main anomaly is that you have both PCs and phones on the same vlan, which should be avoided. If you cannot implement vlans to separate traffic, you can either disable dhcp server on cisco phone system (and give phones static IPs) or fix the 2 DHCP servers in a way that they do not mess each other.
In you actual situation, if i understand well, PC and phones get their IP from either a dhcp server for PC or the Cisco phone system: you might as well have a unique dhcp server giving the same DNS parameter. It will be just a workaround, due to the fact that phones and PCs should be on different subnet.

hope this helps
max
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 41844712
Hi,

It seems, that you not configured vlan for PHONES, or you not configured properly the switches, if you use cisco swithes you need

Switch#conf t

Switch(config)#interface GigabitEthernet <interface ID>

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode access

Switch(config-if)#switchport voice vlan <Voice VLAN ID>

Switch(config-if)#switchport access vlan <VLAN ID>
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 41847068
I appreciate all the comments. Here is some more infor:
  • The phone system has been installed for about 3 years.
  • All the phones have their own wiring back to the phone system.
  • We do not have a managed switch on site.
  • The laptop connections worked perfectly until a couple of weeks ago when, after no changes, the wireless started getting wrong IP information.
  • Although I may be able to sell the boss on a managed switch, as it did work before for years, I am thinking that the managed switch, although nice to have, isn't required.
  • The Wi-Fi comes from the router and the computers using wired connections do not have an issue.
0
 
LVL 23

Expert Comment

by:masnrock
ID: 41847306
Is the firmware up to date on all devices? Have you checked the settings for the WAPs and/or WLAN controller? You also might want to check the switch settings for the ports the WAPs are on.
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 41847813
Hi,

The laptop connections worked perfectly until a couple of weeks ago when, after no changes, the wireless started getting wrong IP information.

it may well be that the dhcp server used so far has run out of IP addresses: you should check there.

max
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 41851211
I ahve determined that the IP information that the wireless devices are getting is coming from the Cisco UC500 Phone System. If I can figure out how to disable the wireless, my problem would be solved.
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 92

Assisted Solution

by:John Hurst
John Hurst earned 250 total points
ID: 41851216
Log into the Cisco wireless and disable Wi-Fi
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 41851219
I will, but I have to determine the CLI to do that. I am not bilingual. I don't speak Cisco.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 41851235
Perhaps a Cisco expert will look in here.
1
 
LVL 23

Expert Comment

by:masnrock
ID: 41851249
Do you have the Cisco Configuration Assistant? You might be able to work that way to get it disabled.
0
 
LVL 23

Accepted Solution

by:
masnrock earned 250 total points
ID: 41851298
Here's a link to download Cisco Configuration Assistant:
https://software.cisco.com/download/release.html?mdfid=281010085&softwareid=281161599&release=3.2(3)&relind=AVAILABLE&rellifecycle=&reltype=latest&i=rm

And here is a link that talks a bit about configuring wireless on a UC500:
https://supportforums.cisco.com/document/34261/wireless-security-cisco-unified-communications-500-series-cisco-smart-business

Basically, this gives the sections you need to go to in order to work on wireless settings, but you will instead be looking to delete or disable the wireless related settings.
0
 
LVL 1

Author Closing Comment

by:LostInWindows
ID: 41873385
Thanks to all who submitted comments. Now that we have Wi-Fi disabled on the cisco, everything works as I exect it to.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 41873387
Thank you for your update and I was happy to help you resolve your issue.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now