Solved

How to disable multiple Remote Desktop sessions in Windows 7

Posted on 2016-10-14
8
43 Views
Last Modified: 2016-10-29
I have a client workstation I need to Remote Desktop into and connect with the currently logged in user's session, but when I RDC in with the current user's credentials I get a new session, not the current user's session. How do I disable the multiple session feature? This workstation is not part of and Active Directory domain.
0
Comment
Question by:jmarkfoley
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 91

Expert Comment

by:John Hurst
ID: 41844520
So far as I know you cannot do this with Windows RDP. You CAN do this with Radmin Tools (Famatech). I put the server on my home desktop and I can access the current session with the Radmin Viewer. There are other third party tools, but Radmin may also be used without a user on the other end.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 41844663
Windows 7 Computers do not allow multiple desktop sessions.  If you RDP in, you take over the console and the user session for that user (if one existed).  If you are getting multiple sessions, then someone probably hacked it.  Make sure you correctly patch it it up to date and it should work as you want.  The behavior you want is EXPECTED behavior for unaltered Windows 7 Pro/Enterprise/Ultimate systems.
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 41844934
Check if Fast User Switching is off - it should, and in a domain automatically is. Having it off doesn't allow for multiple sessions, the current session is taken over or needs to get terminated.
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 41844983
John Hurst:
So far as I know you cannot do this with Windows RDP.
Lee W, MVP:
Windows 7 Computers do not allow multiple desktop sessions.
I didn't think so either, but it is definitely doing it. I doubt someone there installed any hack as they are rather computer-simple. Others have reported this same issue, for example: http://superuser.com/questions/491385/on-windows-7-x64-how-can-i-disable-multi-session-in-rdp. I will check the installed programs to see if anything is funny.

Qlemo:
Check if Fast User Switching is off - it should, and in a domain automatically is. Having it off doesn't allow for multiple sessions, the current session is taken over or needs to get terminated.
Where would I check for "Fast User Switching"? The workstations is not in a domain.
0
ScreenConnect 6.0 Free Trial

Check out the updates in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI that improves session organization and overall user experience. See the enhancements for yourself!

 
LVL 91

Expert Comment

by:John Hurst
ID: 41844986
I didn't think so either, but it is definitely doing it

Can you show some kind of screen shot?

Any and all times I have RDP'd into a Windows Machine even with my own user name that was on the machine I was logging into, it logged off and made me sign in.
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 41845058
For controlling Fast User Switching, see the different approaches described e.g. in http://www.maxi-pedia.com/disable+fast+user+switching+windows+7 .
0
 
LVL 1

Accepted Solution

by:
jmarkfoley earned 0 total points
ID: 41845691
I believe I've fixed it, but will have to go on-site to be sure. In any case, I appear to now be getting the logged-in user's desktop. I used the instruction in that link I posted: http://superuser.com/questions/491385/on-windows-7-x64-how-can-i-disable-multi-session-in-rdp, as follows:

Start > run gpedit.msc > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections > Restrict Remote Desktop Services to a single Remote Desktop Services Session = 'enabled'

I will confirm with the on-site user tomorrow and post back.
0
 
LVL 1

Author Closing Comment

by:jmarkfoley
ID: 41865069
I found the solution
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

4 Experts available now in Live!

Get 1:1 Help Now