Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 242
  • Last Modified:

Screen saver not working

I have a serious problem. 3 of the 10 Windows 7 workstations in our office have had the screen saver stop working. They are set to 20 minutes, blank, ask for password. They are ignoring these settings. Two of the workstations are currently logged of, but the login screen stays up -- all night, over the weekend, etc. The 3 is logged in and the user's desktop stays up and visible. This is especially bad as anyone could get onto this user's computer and do whatever they want.

Why is this happening and how can I fix it?
0
jmarkfoley
Asked:
jmarkfoley
  • 3
  • 2
  • 2
  • +1
2 Solutions
 
John HurstBusiness Consultant (Owner)Commented:
Find the manufacturer's power driver for these workstations, download and install it. Then reset the settings. Finally, shut down, start up and then test.
0
 
n2fcCommented:
The screen saver is NOT a global (PC wide) setting!

It is associated with an individual account only.

By logging off (and going to the logon screen) you have effectively turned off the screen saver until the next logon!

Your only other choice is to change the "lock screen settings" as shown in the following article:
http://windows.wonderhowto.com/how-to/customize-windows-10-lock-screen-0163510/

You can also try the following article's recommendation...
Although written for Server 2003, I believe it will still work on WIN 7...
https://support.microsoft.com/en-us/kb/185348
0
 
RaghavIT SpecialistCommented:
For win 10 - Please check if any USB device is connected to the PC. Unplug it and check if screen saver works.

For Win 7 -

Check following string in the registry. Ensure it is set to "0" -

"HK_Current_user\control panel\Desktop -> ScreensaverActive = 0"

I second John. You need to select best power settings that suits your needs.

Good Luck

Best Regards
Raghav.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
n2fcCommented:
Another article (from Microsoft) supporting MY answer:
http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/no-screen-saver-at-windows-7-welcomelog-in-screen/a437ee54-6f7f-48fd-8413-7338480948d8

===
You can enable the logon screensaver by adding a couple of registry values.

One of the problems that you have is that Direct3D support is not enabled on the login screen which means you can't use any of the Windows 7 stock screensavers.  With this in mind you can either download one of your choosing from the web or grab the LOGON.SCR file from a Vista machine.  The file will be in C:\WINDOWS\SYSTEM32 - copy it to the same location on your Windows 7 machine.

Now, open the registry editor and go to HKEY_USERS \ .Default \ Control Panel \ Desktop

Below this key create the following REG_SZ values...
SCRNSAVE.EXE = C:\WINDOWS\SYSTEM32\LOGON.SCR (or whatever your file is called).
ScreenSaveActive = 1
ScreenSaveIsSecure = 0
ScreenSaveTimeOut = 60 (or whatever timeout you want in seconds)
That's it - you'll have your screensaver at the logon screen then.  I
0
 
jmarkfoleyAuthor Commented:
Registry settings for HK_Current_user\control panel\Desktop are the same for all workstations, functioning properly or otherwise:
Registry settings for Screen Saver in HKEY_CURRENT_USERFor all computer, there are no screen saver related settings in HKEY_USERS/.Default.

The screen saver for all computers (right-click desktop > Personalize > Screen Saver) is set to 'Blank", 20 minutes, On resume, display logon screen.

Power options on the troublesome workstations were grayed out, not so on properly functioning workstations. I clicked "Change settings that are currently unavailable", and set them to blank screen after 30 minutes. I'll see what that change does before trying the other suggestions.
0
 
jmarkfoleyAuthor Commented:
It doesn't make sense, but clicking on the power options "Change settings that are currently unavailable" and setting the "Turn off display: 30 minutes" (which is what it was anyway, just greyed-out) fixed both the turn of display problem and the screen saver problem. Both now work properly, no changes to registry, no drivers downloaded. Problem solved. For extra credit, I'll leave this open for a bit in case someone wants to offer any theories.
0
 
RaghavIT SpecialistCommented:
Good to know that you were able to fix this problem.

Screen saver is a part of power saving options and you need to tweak power saving profile as per your needs.

You did the same thing.

--Raghav
0
 
jmarkfoleyAuthor Commented:
I figured it out.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now