Can't send as from a mail enable public folder

I have a user that each time he try to send as from a mail enable public folder he gets an error that  This message could not be sent. Try sending the message again later, or contact your network administrator. You do not have the permission to send the message on behalf of the specified user.
How do I set that permission on Exchange 2016?
Who is Participating?
Niten KumarConnect With a Mentor Principal Systems AdministratorCommented:
Go to Toolbox in EMC and then click on Public Folder Management Console.  Look for the particular mail enabled public folder and right-click on it and go to properties.  Click on Mail Flow Settings tab and then on Delivery Options.  Click on properties and add the user.
Edwin HofferTechnical ExpertCommented:
Dear User

You can refer the following Microsoft article to resolve same issue:

If it doesn't get resolved then you can refer to a solved exchange expert query:

Thanks & Regards
Edwin Hoffer
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.