RDP through VPN setup

I have a client that is using the following setup:
1. establish VPN connection to service provider
2. start RDP session to the service provider (through the VPN)

However, during the VPN session, the client can't use local resources (print etc.)
I have tried to disable 'use default gateway on remote network' but than the RDP client can't establish the connection.

The client is using Windows 7, with generic MS VPN client and MS RDP client

is there a way to force the RDP session through the RDP without enabling the default gateway on remote network?
ivolachAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
KimputerConnect With a Mentor Commented:
In that case, it's some strict configuration on the gateway's side (firewall and RDP restrictions probably).
Not being able to use local resources is a separate issue. Both needs to be fixed by the system admin in charge there.
0
 
KimputerCommented:
If you use the IP number of the RDP "server", the "default gateway" option DOESN'T need to be on.
Local resources not being available though, is probably a server restriction, not a VPN or RDP problem.
Ask the admin to give you permission for local resources (obviously, you didn't forget to check the boxes in the connection settings, right?)
0
 
ivolachAuthor Commented:
not sure what you mean check the boxes.
when the 'use default gateway on remote network' is checked, I have no problem connecting the RDP

If I check the 'use default ....' off, I can't establish the RDP connection.

Are you saying the remote server is not allowing the split tunneling?
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
KimputerCommented:
Just use the IP number first, then get back here with the result.
0
 
ivolachAuthor Commented:
not sure what do mean use the IP number first
0
 
KimputerCommented:
When you connect to the RDP, use IP number.
Report back if you can connect.
0
 
ivolachAuthor Commented:
I am using IP address in the RDP client and I can't connect if the 'use default gateway....' on the VPN is checked off.
0
 
Rob WilliamsCommented:
If the local and remote subnets are the same, such as both site using 192.168.0.x you will experience this, when enabling and disabling remote default gateway..  For routing to take place each site must use a different subnet such as 192.168.0.x and 192.168.10.x.
0
 
ivolachAuthor Commented:
they do use different subnets.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.