Solved

Windows 7 keeps losing its IP configuration

Posted on 2016-10-20
15
100 Views
Last Modified: 2016-11-03
Hi

A Windows 7 64bit Lenovo Thinkpad e540 seems as if it keeps losing its IP configuration (+ ESET NOD32)

The user tries to reach certain websites and obtains a can't reach error instead, with IE, FF and Chrome
One of the sites is her bank's website - Google or MSN websites however obtain the same treatment

Pings to FQDN and IP adresses are answered

If I reset the IP layer:

ipconfig /flushdns
netsh winsock reset
netsh int ipv4 reset catalog
netsh int ip reset c:\reset.txt

...and reboot the computer, the user can access all websites again

She noticed that this morning she was on the bank's website at 8.50am and then when she tried to access the site again at 8.57am the site was unreachable
Nothing really happened in between except for a print out of a bank statement and a telephone call

I'm stumped

any ideas ?

thanks
yann
0
Comment
Question by:Yann Shukor
  • 5
  • 4
  • 3
  • +3
15 Comments
 
LVL 5

Expert Comment

by:Austin Texas
ID: 41852141
I am assuming there are other people on the network and they are not experiencing the same issues.

What does the network look like? Ethernet? WiFi? What network equipment?
0
 
LVL 5

Expert Comment

by:Austin Texas
ID: 41852147
I recently dealt with a case where devices on a WiFi network using a LinkSys EA4500 were periodically losing connectivity *individually*. I discovered the problem would resolve on reboot of the EA4500 and I also noticed it was running hot, so I improved airflow to the EA4500 and so far so good. Not what I would have expected.
0
 
LVL 28

Assisted Solution

by:Michael Pfister
Michael Pfister earned 62 total points
ID: 41852154
Check if you have the latest drivers for LAN/WLAN for your model on the Lenovo web site:
http://support.lenovo.com/
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 3

Assisted Solution

by:Ertan SENOYAR
Ertan SENOYAR earned 62 total points
ID: 41852157
DHCP and DNS client Services need to be running all the time in order to get and renew IP lease from DHCP.Can you check if your DHCP and DNS client services running while you are experiencing trouble..
0
 
LVL 9

Assisted Solution

by:Dan Arseneau
Dan Arseneau earned 62 total points
ID: 41852327
Open CMD as Administrator
Type in:

Set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Open in new window


View menu -> Show Hidden Devices..
Open up Network Adapters
See if you have any duplicate devices.  If you do, and they're greyed out, right-click and uninstall it
0
 

Author Comment

by:Yann Shukor
ID: 41852395
Thanks for your suggestions Tex
 - PC is connected via Ethernet - Zyxel 24port Switch
 - Other users are all fine
 - This situation occurs at both sites where this user works

Thanks for your suggestions mpfister:
 - I will check if the drivers and bios are up to date

Thanks for your suggestions Ertan:
 - these two services are in effect and set to automatic

Thanks for your suggestions Dan:
 - will check this tomorrow
0
 
LVL 5

Accepted Solution

by:
Austin Texas earned 252 total points
ID: 41852490
Given that information, I concur with mpfister that checking the drivers is a next step.

If that falls short or doesn't work, I would also suggest that you consider putting a new network interface card on it and then see if the problem persists.
0
 
LVL 19

Assisted Solution

by:marsilies
marsilies earned 62 total points
ID: 41852698
Is it all websites, or just secure websites?

Make sure the date and time settings are correct on the PC.

Check the proxy settings to make sure malware isn't rerouting traffic. Also do a malware scan.
0
 

Author Comment

by:Yann Shukor
ID: 41862289
Well folks

DNS and DHCP services are on and launched automatically

There are no duplicate hidden network interfaces

I updated the BIOS and WIFI drivers, and reinstalled LAN drivers, but the situation is occuring
any other suggestions ?

thanks
yann
0
 
LVL 5

Expert Comment

by:Austin Texas
ID: 41862487
Have you tried an another NIC like a USB NIC to see if you get similar results? If you get the same results with another NIC then we would know it is not a hardware issue.

On the other hand, if the new NIC works reliably, then we could probably surmise that it is localized to the NIC or the driver.
0
 

Author Comment

by:Yann Shukor
ID: 41862496
Thanks Austin, I have ordered one off amazon and will test this
For the moment I asked that the user stick to using Wifi access to see if this issue is related to the network interface
1
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 41862862
Are they carrying the Ethernet cable with them?  Make sure you swap the cable also.
0
 

Author Comment

by:Yann Shukor
ID: 41862875
Nope, different cable each time
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 41862925
With all your work, I agree that the adapter is probably gone bad.  USB to Ethernet is your friend...as Austin mentioned.
0
 
LVL 5

Expert Comment

by:Austin Texas
ID: 41873302
Thanks for the points! Did the new NIC resolve the issue?
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
You may have a outside contractor who comes in once a week or seasonal to do some work in your office but you only want to give him access to the programs and files he needs and keep privet all other documents and programs, can you do this on a loca…
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question