IIS8, 2012, IIS SSL - Website loading issue

error of webpage
I am trying to make a simple intranet website I made on a 2012 R2 server work so that it uses SSL to protect a login page on it that requires a password.

I did not purchase a cert. I've done the followign:

1. Installed IIS and on the top level settings went to "Server Certificates"
2. Clicked "Create Self-Signed Certificate"
3. Went down a level to my Default Web Site and clicked "Bindings"
4. Added type https, selected the SSL certificate I created in step 2.
5. Clicked SSL settings for Default Website, clicked "Require SSL" and chose Accept as well as Require between attempts.

But when I visit the site I now get a prompt to confirm the cert, and then the error message above.

If I turn off require SSL, the site loads fine... http://server.domain.com/Page
but the error is when I try: https://server.domain.com/Page

Is there an easier way to make this work without getting too complicated?
garryshapeAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Visitors will always get the warning because a self-signed certificate can not be traced to a Certificate Authority.  While they can accept it as an exception, you can not turn that message off.
0
 
garryshapeAuthor Commented:
Well the issue is the website will not even load at all with SSL set to required, as shown in the error screenshot.  
The website only loads if SSL required is unchecked :(
0
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
I'm not sure that is a completely accurate error message.  What does it say when you click on 'More Information'?
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
garryshapeAuthor Commented:
The More info says:

This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.

Interestingly, in Firefox, it comes right up. Although I had to click Add Exception in Firefox.
0
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Please click on "Request Attention" above and get some others to look at your question.  I'm out of ideas at the moment.
0
 
ArneLoviusConnect With a Mentor Commented:
Are you testing with IE and Firefox on the computer hosting the website, or a different computer ?

If on a different computer, were you using IE and firefox on two different computers, or the same computer ?

do you have any authentication enabled in IIS ?
0
 
garryshapeAuthor Commented:
It's on the same computer, no special settings on authentication. It allows anonymous from what I'm seeing.  

Really I just want to make it so password is secure, I'm not sure what the bare minimum is for doing that. Even if I don't to have a certificate that's what i'd like to achieve at the very least. Even if there's a browser security prompt.
0
 
Dan McFaddenConnect With a Mentor Systems EngineerCommented:
Can you post some lines from the http logs where you get the SSL error?  Also, are there any errors or warnings in the Application Event Log associated with IIS?

Can you post a screenshot of the site bindings?

Dan
0
 
garryshapeAuthor Commented:
It just fixed itself so I'm not sure what happened.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.