Solved

redistribute default route to EIGRP?

Posted on 2016-10-24
2
44 Views
Last Modified: 2016-10-29
I have the below setup. sw1, sw2, and sw3 are configured for EIGRP. sw3 has a default route pointed to the the FW (thus accessing the Internet). sw1 & sw2 will need to go through sw3 to get to the Internet. Is there a way to redistribute the default route on sw3 to EIGRP so that sw1 and sw2 know how to get to the Internet? Thanks

sw1_layer3<-->sw2_layer3<-->w2_layer3<-->FW<-->Internet
0
Comment
Question by:leblanc
  • 2
2 Comments
 
LVL 27

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 41857996
Create static default route and then redistribute it into EIGRP:

ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
router eigrp 1
redistribute static metric 100 1 255 1 1500    <---- or default-metric 100 1 255 1 1500 (with whatever metric you want to assign)


By use of summary route on interface(s) to other devices:

router eigrp 1
network 10.0.0.0
!
interface fa0/1
no switchport
ip address 10.0.0.1 255.0.0.0
ip summary-address eigrp 1 0.0.0.0 0.0.0.0

Details in article - Configure Default-route in EIGRP
0
 
LVL 27

Expert Comment

by:Predrag Jovic
ID: 41864951
Just for the record, the same also can be achieved by:

1.
ip route 0.0.0.0 0.0.0.0 fa0/0
!
router eigrp 1
 network 0.0.0.0
!
ip default-network 0.0.0.0              <--in this case edge router sends traffic to fa0/0 interface

edge router partial output
sh ip route

Gateway of last resort is X.X.X.X to network 0.0.0.0    

D*   0.0.0.0/0 [90/332800] via X.X.X.X, 00:00:17, FastEthernet0/0    <--- where X.X.X.X is address of router in direction of edge router

2. way (not having 0.0.0.0 0.0.0.0 route)

ip route 20.0.0.0 255.255.255.0 <next-hop>
!
router eigrp 1
redistribute static metric 100 1 255 1 1500
!
ip default-network 20.0.0.0

eigrp 1 non edge router partial output
sh ip route

Gateway of last resort is X.X.X.X to network 20.0.0.0

D*EX 20.0.0.0/8 [170/256053760] via X.X.X.X, 00:04:40, FastEthernet0/0        <--- where X.X.X.X is address of router in direction of edge router
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port forwarding 14 118
Super Scope, DHCP 5 53
Cisco ASA version 8.2 NAT to version 9 NAT 3 29
How can I measure the quality of my Internet access? 2 28
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now