Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

FTP Connect Error PORT Command Failed Failed to retrieve directory

Posted on 2016-10-25
4
Medium Priority
?
148 Views
Last Modified: 2016-11-02
We are using a MS FTP Server with IIS 6.1.  Our client has been running a FTP job weekly just fine for sometime with no connection issues.  Last Thurs they all of a sudden cannot connect.  No changes to the FTP server or Firewall were made to my knowledge.  We have a NAT rule in place to allow ftp and route from the pub address to local server IP and have not had an issue until this past thursday.  Im unsure what has changed but we get a error when trying to connect from outside as any users "PORT Command Failed Failed to retrieve directory"
0
Comment
Question by:Twhite0909
  • 3
4 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 41858831
make sure that ftp ports are allowed / accessed : 20 + 21.

Please see below link fore more info on ftp ports:

http://slacksite.com/other/ftp.html
0
 

Author Comment

by:Twhite0909
ID: 41862910
Ports are allowed.  This is not a Firewall issue.  We were running a normal FTP site from IIS 6 with users connecting just fine before.  The only change was when I installed an SSL cert for a new WEBFTP server using IPSwitch's WS_FTP software.  Now WS_FTP and FTP have both been running fine on this one server but when I added the SSL cert I also installed adhoc module and a WEB Transfer module.  Im thinking it messed with IIS settings and screwed up the normal FTP site?  Users get

"503 User cannot login, home directory in accessible"
0
 

Accepted Solution

by:
Twhite0909 earned 0 total points
ID: 41862972
I should say the PORT cmd is gone.  There was a change on the IIS FTP settings where someone had entered in an external address.  we removed that leaving the field blank and one account was able to access FTP but the other 2 were not.  In troubleshooting why users were getting the "directory is in accessible" error I changed the FTP Site FTP User Isolation settings from " isolate Users. restrict Users to the following directory:  User name directory (Disabled global virtual directories)  TO  "DO Not Isolate Users. Start Users in Username directory".  I restarted IIS which it seem to hang at stopping but then stopped after 1 min and started back up.  Users including the one who was working got a "User cannot  log in" error and nothing about directory.  Thinking it was what I changed I changed the isolation settings back and restarted IIS again and now all 3 users get the "Home Directory In accessible" error.
0
 

Author Closing Comment

by:Twhite0909
ID: 41869867
;ksdhgfo;jdfhn;lcnvb'l;cxvfb
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

927 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question