SonicWall blocking WOL

I downloaded the NirSoft WOL program. If I plug my comp into a hub I can wake the machine no problem. When I connect through my SW 2400 no good. SW is setup to route. X0 is, X1 Wan, X3 is and X5 is I have read a 100 how to's on this and it couldnt be anymore straight forward.
Enable IP helper, keeping defaults but it doesnt work!
Is there a magic trick to this?
LVL 11
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You need to use ip helper.  Take a look at...

If not obvious where to go, search on WOL.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BillBondoAuthor Commented:
Im sure I have done all of that but will go over one more time tonight. Even creating my own relay. tks
Blue Street TechLast KnightCommented:
Hi BillBondo,

Isn't the hub located downstream from your SonicWALL? If so which network is it connected to and which network are you plugging into when you try to in the SonicWALL?

You specified three different networks of which we don't know their function...meaning i assume you LAN is on X0 but what is X2 & X3 used for? With IP Helper you must specify the network interface of where you want to apply it. If you get this wrong it won't work.

Let me know how it goes!
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

J SpoorTMECommented:
WOL is a broadcast (by default unless otherwise specified).

As carlmd said, you need to IPHelp this.
BillBondoAuthor Commented:
@ deverseit. X2 and X4 are not assigned. All my computers connect through the SW.  I have multiple comp's and two servers.  I am using hubs to connect to X0 and X5.
X0 is
X1 wan
X3 is
X5 is

all are
Comp I am trying to wake is directly connected to X3
My laptop is connected to X5
Everything works perfectly fine so its not a routing/wiring issue. Except for WOL

IF I plug the comp I am trying to wake into the hub I am connected to I can wake the comp. So  WOL itself does work.

I will try again the article from carlmd tonight.
Blue Street TechLast KnightCommented:
yes this is because you need to assign the WOL to X3 and X5 via IP Helper.
BillBondoAuthor Commented:
Pretty sure I did everything correct. Still no good. Decided to connect a linksys just using the switch ports, basically making it a hub to X3 and the comp to the linksys. Worked. Shutdown and tested and worked. Went back to direct connect and it worked. WTF. Tested again and DID NOT WORK this time.

Im limited in time in the evening but I will test those scenario's again tonight.
Blue Street TechLast KnightCommented:
Can you screenshot your IP Helper settings? Also, Maske sure the Access Rules between Zones are set to any, any, allow, all at least for testing purposes in the event you are filtering traffic between Zones.
BillBondoAuthor Commented:
Everything is correct. This SW actually is my companies old one before they upgraded. It has an lan,lan,any,any,allow.  Here is the skinny....

When I plug the comp Im trying to wake directly into X3 I dont even get lights on the port. The comp does show lights. Looking at the SW portal X3 shows 1G connection, odd. I tried every possible scenario (approx 10) and for what ever reason actually worked one time and that was when I tried a different cable. Failed three attempts after that.


Again I take my Linksys and run the SW and comp through that. Works every time. Port on the SW actually has connectivity lights and the portal now says 100M.

So its something to do with the direct connection. And it shouldnt. I cant imagine it has anything to do with the port speed. I didnt find where to manually set port speed. Why would the X3 port not have any lights when directly connected? Cant imagine needing a crossover. I realize direct connection is probably not the usual way of doing things but...

BillBondoAuthor Commented:
Think I figured it out. The SW needs to be the same port speed as what its connected to. Even though it was on auto didnt matter. I was messing around with a cisco poe switch and was getting same issue of no connection. When I changed the SW to 100Mgs wala.
BillBondoAuthor Commented:
port speed mismatch is what seems to have been the issue(s)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.