Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 275
  • Last Modified:

register vmware inventory not succeded

hello,
i've vcenter 5.5 in win2008R2 with external SQL DB 2008, i found the inventory service stopped and can't start it also effected when i try to access the vsphere web client it gives me this error (Unable to connect to vCenter Inventory Service), when i try to re-register it again it gives me this error:
Stopping Inventory Service!
The VMware vCenter Inventory Service service is not started.

More help is available by typing NET HELPMSG 3521.

Code  stopping Inventory Service.
Inventory Service must be stopped and restarted before taking any further action
.
Intializing registration provider...
Getting SSL certificates for https://machinenme.local:7444/lookupservice/sdk
The specified principal (InventoryService_2016.09.19_152043) is invalid.
com.vmware.vim.sso.admin.exception.InvalidPrincipalException: The specified principal (InventoryService_2016.09.19_152043) is invalid.
        at com.vmware.vim.sso.admin.client.vmomi.impl.VmomiClientCommand.execute
(VmomiClientCommand.java:110)
        at com.vmware.vim.sso.admin.client.vmomi.impl.VmomiClientCommand.execute
EnsuringDomainErrorIs(VmomiClientCommand.java:220)
        at com.vmware.vim.sso.admin.client.vmomi.impl.VmomiClientCommand.execute
EnsuringDomainErrorIs(VmomiClientCommand.java:207)
        at com.vmware.vim.sso.admin.client.vmomi.impl.PrincipalManagementImpl.cr
eateLocalSolutionUser(PrincipalManagementImpl.java:197)
        at com.vmware.vim.sso.admin.client.vmomi.impl.PrincipalManagementImpl.cr
eateLocalSolutionUser(PrincipalManagementImpl.java:185)
        at com.vmware.vim.install.cli.commands.RegisterSolutionCommand.execute(R
egisterSolutionCommand.java:48)
        at com.vmware.vim.install.cli.commands.CompositeCommand.execute(Composit
eCommand.java:38)
        at com.vmware.vim.install.cli.RegTool.execute(RegTool.java:190)
        at com.vmware.vim.install.cli.RegTool.process(RegTool.java:107)
        at com.vmware.vim.install.cli.RegTool.main(RegTool.java:38)
Return code is: AlreadyRegistered
7
Error 7 registering with https://machinename.local:7444/lookupservice/
sdk. Cannot continue.
7
i didn't change any default port
0
asfourcrystal
Asked:
asfourcrystal
  • 2
  • 2
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
either restore a backup, or re-install/upgrade in hope it fixes the issue.
0
 
asfourcrystalAuthor Commented:
thanks Mr.Andrew for replay i need also to check for something from you if you allow please, if i install fresh copy of the OS and install also fresh vcenter for example v6 and point the database for my external DB that i used now, shall i found all the cluster as i drew it before and nothing change or i've o create the clusters from the beginning and add the host in?

thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you use the same database, if you decide to upgrade to 6.0, it will be the same.

e.g.

shall i found all the cluster as i drew it before and nothing change or i've o create the clusters from the beginning and add the host in?

the same after upgrade.
0
 
asfourcrystalAuthor Commented:
many many thanks Andrew for the answer :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now