Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2010 / Outlook 2010 - search results not returning everythig that it should

Posted on 2016-10-26
5
Medium Priority
?
163 Views
Last Modified: 2016-11-15
Hello,

We are running an Exchange 2010 server.  I have an Outlook 2010 client that is experiencing the following issue:

When user conducts searches, he is not receiving the full results.

Action taken:
- Completed a re-index.  It took a few days to complete, but the results are no better.
- Setup new profile.  This also took some time to synch up with the server and complete indexing.  However, the search results are still not listing everything that it should.
- I've verified that the option to limit search results is not checked.
- I have created a separate profile that is in non-cached mode.  This DOES return all the results that it should.

What further action could I take to address this issue?

I'm not sure if this is related, but the problem appears to have started after indexing was done on the Exchange server followed by a Information Store stop/start.  This was done because searches using the Discovery Tool was not returning all results.  

I really would like to switch back to the cached profile.  

Thanks in advance.

Regards,
Real-Timer
0
Comment
Question by:realtimer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 13

Assisted Solution

by:Michael Machie
Michael Machie earned 1000 total points
ID: 41861457
Outlook 2010 on exchange 2010 has a known limitation when searching. Some service packs only allow up to 50,000 instances of the search criteria to populate  and other service packs allow up to 200,000. However, I have personally identified a limitation of 20,000. So, if you search for the letter 'A', a max of 20,000 random instances of 'A' will populate. The remaining will not be found.

Narrow your search down by adding as much criteria as possible to the search as possible and you must be exact in your spelling.
0
 

Author Comment

by:realtimer
ID: 41861464
Thanks.

I've tried a search for "FirstName LastName".

On cached, this returns about 10 messages in the year 2016.
In non-cached, it returns about a hundred going back to 2014.
0
 
LVL 13

Accepted Solution

by:
Michael Machie earned 1000 total points
ID: 41863047
Its funny, I literally just ran into this with a VP a couple hours ago.

The 'Windows Search Email indexer' add-in was not enabled and after enabling it more results displayed. This was because when he searched the mailbox and the add-in was not enabled, the results were taking literally an hour to display everything as Outlook needed to search all emails for that criteria in order to display them in a timely fashion. Did you allow the search to continue for an extended period of time? If yes, did you cancel the search before it completed displaying all results?

Not saying enabling that add-in will fix your issue but if you can verify it is enabled we can tick that off the list.
outlook -> File -> Options -> Add-Ins -> Check to see if 'Windows Search Email indexer' is listed.
If not:
At the bottom of the Add-Ins window:
['Manage:' drop down] Disabled Items -> Go...
In the little window that appears you may see ''Windows Search Email indexer'. If you do, Select it and click 'Enable' to the left of 'Close'. Then 'Close', 'OK', Re-launch Outlook and re-search.

If 'Windows Search Email indexer' is not seen anywhere then that could be your root issue because that Add-In searches your .OST, which is essentially your 'Cached' data file.
0
 
LVL 8

Assisted Solution

by:Lisa Hendrickson "CallThatGirl"
Lisa Hendrickson "CallThatGirl" earned 1000 total points
ID: 41863098
Might want to make sure the computer indexing is setup right too. I have found that to be a mess. Go to the control panel on the pc/ go to Indexing and be sure the path is correct.
0
 

Author Closing Comment

by:realtimer
ID: 41888897
The issue still remains.  However, I think it would be fair to award some points for the assistance.

Thank you.
1

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question