Solved

530 User cannot login, home directory inaccessible

Posted on 2016-10-28
18
57 Views
Last Modified: 2016-11-11
FTP on II6 with NTFS permissions to home directories are in place.  ALL PORTS on Firewall are in place ALL NAT rules on firewall are in place.  This has been working fine until we installed WS_FTP to this server and ran a few modules.  Im not sure what broke bc all the FTP sites in IIS look fine.  The permissions look OK.  I have the application pool identity set with permissions to the folders.  SO unsure what happened but users get the error now when they log into port 21 FTP
0
Comment
Question by:Twhite0909
  • 9
  • 9
18 Comments
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864052
0
 

Author Comment

by:Twhite0909
ID: 41864065
Well here is the kicker. 1 account works fine.  the others do not and any news accounts get same error.  The one account is identical in eveyrway (it seems) I am just trying to pur over it all to see what did I miss?
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864067
Is this account have any special access rights to the data area ?
A security group it is part of?
0
 

Author Comment

by:Twhite0909
ID: 41864084
I also tried the link. Good shot but still nogo after adding FTP auth rule to allow all users read/write then restarting the FTP service
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864090
what happens if you try locally accessing the ftp site, ie local network ?
restart the server fully.
0
 

Author Comment

by:Twhite0909
ID: 41864091
No it is not a member of any group besides local users.  As you can see in the attached
FTPUserAccounts.png
0
 

Author Comment

by:Twhite0909
ID: 41864094
accessing it locally from my own network it sits on I get the exact same error
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864096
OK so this is not a domain based server ?
What is the security on the folders / share ?
0
 

Author Comment

by:Twhite0909
ID: 41864097
If you help me solve this then your on my xmas list!!!!
1
The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864099
Well ill try my best.
Has any other changes been made ie deletion and recreation of accounts ?
The one account that works is there any difference with the other accounts that you can see.
0
 

Author Comment

by:Twhite0909
ID: 41864104
yes this is a domain based server.  its is a win 2008 r2 server joined to our domain.  USes MS FTP and IIS6.  I didnt mean to confuse things with my wording of "my network" before. Attached are the folder permissions
ftp-folder-permissions.png
0
 

Author Comment

by:Twhite0909
ID: 41864105
as far as differences between the two accounts athere are none I can see
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864106
ok and the port has not changed from 21 to sftp has it ?
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864108
So are users local or domain users ?
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 41864117
Check the number of characters in your hostname, if it is more than 15 characters. Change the hostname to one it has less than 15 char

Check the physical path for FTP sites in IIS > Web sites > IP address > Basic settings > Physical Path.

Is there any reason why you cannot start over again.?

Remove FTP publishing from the site.
Restart IIS
Verify that the users have proper permissions to the folder you want them to use.
Add FTP publishing back to the site.
Add the user to the ftp authorization rules.
0
 
LVL 19

Accepted Solution

by:
Zaheer Iqbal earned 500 total points
ID: 41864127
Also how has FTP user isolation been configured?
0
 

Assisted Solution

by:Twhite0909
Twhite0909 earned 0 total points
ID: 41864152
Users for FTP are created locally on the server

FTP User isolation has been configured to Isolate Users. User Name Directory (Disable global directories)

BC the one user account that sends files 3 times a day is working mgmt does not want us  creating another FTP and starting again.
0
 

Author Closing Comment

by:Twhite0909
ID: 41884034
ytujytjghb
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I had a question today where the user wanted to know how to delete an SSL Certificate, so I thought that I would quickly add this How to! Article for your reference. WHY WOULD YOU WANT TO DELETE A CERTIFICATE? 1. If an incorrect certificate was …
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now