MySQL not outputting all Emojis in text field when using UTF8MB4

We have a project where we're storing Facebook and Twitter posts in a Mysql database, as first almost all Emojis were being stored as ?. We've since gone ahead and made some configuration changes to the database server, and since then we're starting to see more Emojis saving and appearing correctly, however some Emojis are still showing as ?, sadly I'm not sure which ones they are. I know one of them was a basket ball.

When I execute the following commend on MySQL;

SHOW VARIABLES WHERE Variable_name LIKE 'character\_set\_%' OR Variable_name LIKE 'collation%';

Open in new window


I see the following settings;

character_set_client     = utf8
character_set_connection = utf8
character_set_database   = utf8mb4
character_set_filesystem = binary
character_set_results    = utf8
character_set_server     = utf8mb4
character_set_system     = utf8
collation_connection     = utf8_general_ci
collation_database       = utf8mb4_unicode_ci
collation_server         = utf8mb4_unicode_ci

Open in new window


Our database server is hosted with Rackspace, we've asked them to set up the following configuration;

[client]
default-character-set = utf8mb4

[mysql]
default-character-set = utf8mb4

[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci
init-connect='SET NAMES utf8mb4'

Open in new window


I think I've narrowed the issue down to the server not applying the init-connect that's defined in the server configuration. If I open mysql workbench and query the database, I see question marks in place of emojis, however if I run the SET NAMES query first, then the subsequent results come back showing the emojis as I expect.
SheppardDigitalAsked:
Who is Participating?
 
Steve BinkConnect With a Mentor Commented:
The material at https://laravel.com/docs/5.3/database implies you can set a connection-level charset and collation in the config.  If you set UTF8MB4 there, you could use MySQL's general log to verify what happens at the start of your connection.

I had a similar issue with CiviCRM a while back.  It used SET NAMES but only set the character set, not the collation.  The default collation for UTF8 is utf8_general_ci, but the fields in the db are generally utf8_unicode_ci.  Changing the collation during initial connection save me from many headaches.
0
 
gheistCommented:
It is not executed if connecting user has SUPER privilege.
0
 
Steve BinkCommented:
As noted by gheist, init_connect does not have any effect on non-SUPER users.  I very much doubt you want to give that privilege to your application.

Moreover, your client-based settings will not be enforced on every connecting client.  It will only impact clients using that .cnf file.  And you do need the UTF8MB4 set - some extended characters will not render in vanilla UTF8.

The solution is to have your client (i.e., the application) run SET NAMES as it initializes the database connection.
0
 
SheppardDigitalAuthor Commented:
Thanks Steve,

We're using Eloquent ORM so I'm looking to see if there's a way to call SET NAMES on every database connection.

I did speak with Rackspace and they confirmed that the user didn't have SUPER privileges, so I suspect that you are correct, the client will need to call SET NAMES.
0
 
SheppardDigitalAuthor Commented:
Setting the charset and collation in Laravel's database.php configuration file to utf8mb4 (charset) and utf8mb4_unicode_ci (collation) seems to have done the trick.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.