Solved

Redirect on SBS hosted web not working from linux based browsers

Posted on 2016-10-28
3
89 Views
Last Modified: 2016-11-04
I have a Windows SBS 2011 server that hosts the standard out-of-the-box web pages.  The ones we run and care about are wwwint and companyweb.  

From a windows 7/10 workstation, https://wwwint.company.local works perfectly and drops the user into the company time card system as designed.  It will work correctly from all browsers (that we care about), Chrome, Firefox, and IE.  

From a linux CentOS 6.x box, both from Firefox and Chrome, that same url will give you "403-Forbidden: Access is denied".   This is what I would get, and expect, if I were to address the server (from a windows or linux browser) by hostname directly (https://servername.company.local).  

So, apparently linux based browsers don't get redirected properly.

The questions I have are: is this a known issue (linux browser to sbs hosted web) and is there a fix or is this some kind of active-x thing that will never work?

Any insight is appreciated and thanks for your time.
0
Comment
Question by:Norm_Abrams
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 17

Accepted Solution

by:
Gaurav Singh earned 500 total points
ID: 41864366
Have setup the default page for the local site? Check the permissions of site and also make sure that you able to resolve the DNS from the linux machine
0
 

Author Comment

by:Norm_Abrams
ID: 41864607
Thanks Gaurav, the first part of your reply got me thinking about how or if my default web site was configured.  It turns out my default site is not configured.   That doesn't really matter, but while I was in there I also took a look at wwwint and noticed that it is only setup to accept HTTP transactions and not HTTPS.  I then looked at the Linux boxes and found that Firefox was auto-filling HTTPS whenever I would attempt to go to the wwwint URL, which is why I was getting the failures.  

As I understand it, this behavior from the browser is correct and a result of my server having the STS header set, which tells the browser that all web pages from this domain should be opened using HTTPS.  So, Firefox and Chrome are both behaving properly, it's my site setup that requires a look.

I guess the most likely solution to this issue is to configure wwwint to handle https.
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 41864864
yes it its internal site only seflsgin Certificate will work.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question