Solved

Dual boot of Ubuntu 16 on Acer E-15 E5-575G

Posted on 2016-10-29
6
280 Views
Last Modified: 2016-11-17
Dear Experts.

My laptop is Acer E-15 E5-575G-76YK

After setting up BOOT password, disabling secure BOOT,
installing Ubuntu 64 bit from USB,
the computer still does not show up
GRUB menu, but
only shows up Windows Boot Manager menu if to
click F12 at boot time.

There were no error warnings after Ubuntu installation.

After installation, I rebooted from USB again and ran
boot-repair. Boot-repair reported an error, but not clear which one.
My SSHD is /dev/sda.
Windows is on sda3

Ubuntu on sda5 and 6.

It was a state of hybernate, but I fixed it by "shutdown /s /t 0".

Boot-repair log is attached.

Thank you.
problem-acer-boot-after-shutdown-s-t.txt
0
Comment
Question by:Bitlab
  • 4
6 Comments
 
LVL 70

Assisted Solution

by:garycase
garycase earned 250 total points
ID: 41865525
The F12 menu is a BIOS-level menu that allows you to select the boot DEVICE => NOT a specific partition on that device.

Most likely you need to change the active partition on your system to the partition where you've installed Grub.

Boot to a utility that lets you view and modify the MBR on your disk, and see which partition is currently active.    Note that if you change the active partition incorrectly, the system won't boot ... so be sure to pay attention to which one is CURRENTLY active so you can change it back if you make a mistake.

If you don't have a good disk utility that you can do that with, use Boot-It BM.    Just create a bootable CD; boot to it; click CANCEL at the first prompt (don't install it on the disk); then OK to go to Maintenance mode.    Then click on Partition Work, and you can then click on "View MBR" to see the MBR and change the active partition.
http://www.terabyteunlimited.com/bootit-bare-metal.htm   [Just download it and use the free demo for this]

Incidentally, Boot-It is an EXCELLENT boot manager and partition manager => you may want to consider buying it and using it to manage your multi-boot setup.
0
 
LVL 7

Assisted Solution

by:Raghav
Raghav earned 250 total points
ID: 41865762
Hi,

I will try to answer your question if i am correct in understanding the issue you are facing.

The best option to make your system Dual-Bootable like yours is to install Ubuntu first and assign some free space ( Not Formatted ) for your windows OS.

Once you are done with Ubuntu installation, boot the system with windows media and windows will be able to discover free space for the installation. (Windows does not recognize any ext3 / ext4 file system partitions). Once you are done with both the installations you should be able to choose the OSes while booting.

You can also use any third party boot managers as suggested by garycase.

Hope this helps.

Best Regards
Raghav.
0
 
LVL 2

Author Comment

by:Bitlab
ID: 41866103
Thank you, Experts.

"...Most likely you need to change the active partition on your system to the partition where you've installed Grub...."  this advice seems irrelevant because all 2 partitions on sda are marked active with asterisk

The main problem is that when setting:
   BootOrder: 0000,0001,0002,2001,2002,2003
from live CD and after rebooting, something erases an entry "0000" like this:
   BootOrder: 0001,0002,2001,2002,2003

See details of "erased" settings:

ubuntu@ubuntu:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0002,2001,2002,2003
Boot0000* ubuntu      HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Windows Boot Manager      HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* Linpus lite      HD(1,MBR,0x4294967271,0x2caa70,0x1280)/File(\EFI\Boot\grubx64.efi)RC
Boot0003* Unknown Device:       HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* Unknown Device:       HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Unknown Device:       HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0006* Unknown Device:       HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0007* Unknown Device:       HD(1,GPT,1ff15ea8-2515-4c5c-a793-921644dc83cb,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device      RC
Boot2002* EFI DVD/CDROM      RC
Boot2003* EFI Network      RC
ubuntu@ubuntu:~$

On top of this, efibootmgr does not work properly
   ubuntu@ubuntu:~$ sudo efibootmgr -t 10  
   efibootmgr: Could not set Timeout: Invalid argument

It can be a vendor (Acer)  problem or broken version of
ubuntu@ubuntu:~$ sudo efibootmgr --version
version 0.12

I recall that version 0.24 is good.

The advice to install Windows first? ... I am not in position to spend $150 for Windows media ... just to find out that unknown problem is not resolved ....

Thank you.
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 2

Author Comment

by:Bitlab
ID: 41866104
PS. Sorry for the typo. I meant "... install Ubuntu first ..." not "... Windows first ... "
0
 
LVL 2

Accepted Solution

by:
Bitlab earned 0 total points
ID: 41876268
Solution final step was aka:

...Power on PC
......F2 to go to EFI screen
.........Enable security
.........Enable Security password
.........Go to tab Security
............Select an UEFI file as trusted
...............Single Security tab appears
...................<EFI>
.......................\EFI\ubuntu\shimx64.efi
...........................give it a name: ShimUbuntu and confirm
...Reboot
...This enables ShimUbuntu in F12 menu

Ubuntu dual boots. Time will tell how stable this architecture will work.

Credit belongs to:
...http://askubuntu.com/questions/627416/acer-aspire-e15-will-not-dual-boot                        
......https://forum.ubuntuusers.de/topic/efi-dualboot-mit-acer-aspire-es-15-geht-nicht/            

More details:
...https://www.experts-exchange.com/questions/28979879/Preserving-boot-order-in-EFI-partition.html
0
 
LVL 2

Author Closing Comment

by:Bitlab
ID: 41891156
Setting "trusted" entries in boot-firmware-utility is a final step which solves the problem.
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question