Error : The website cannot be started. Another website may using the same port.

Hi Experts,

I've added the bindings to the IIS default site (for the port number 9680-HTTP & 9643-HTTPS). Whenever I go to click on the start button it could not start and run into an error mentioned in the title above.

Screenshots are as follows :
ErrorStart Default WebsitePorts ListeningPID 4 System Port
How to resolve the error?

Regards,
D Patel
LVL 7
D PatelD Patel, Software EngineerAsked:
Who is Participating?
 
Dan McFaddenConnect With a Mentor Systems EngineerCommented:
The solution is to not use the "All unassigned" IP address binding when you have multiple sites running in IIS.  You can run many sites with a single IP address by selecting the real IP address of the server and using the "Host Name" field in the site binding.

Then you can run multiple sites on port 80 & 443.

Dan
1
 
Dr. KlahnPrincipal Software EngineerCommented:
Download a free copy of Microsoft TCP View and it will tell you what process has acquired each port.  If the issue is due to some (other) process having captured that port, this will reveal the culprit.

Microsoft TCP View
0
 
RaghavIT SpecialistCommented:
Hi,

Just a small hint.

Are you using Skype?  If yes please try quitting Skype and start the IIS.

Best Regards
Raghav.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
D PatelD Patel, Software EngineerAuthor Commented:
Not using the skype.

The problem is on Server.

After installing the AD FS 2.0 it started to arise the problem.

Regards,
D Patel
0
 
RaghavIT SpecialistCommented:
You may try changing the binding on the default website in IIS.

Best regards
Raghav.
0
 
RaghavIT SpecialistCommented:
link below will help you change the listening port of default website.  

https://support.microsoft.com/en-in/kb/149605

Best regards
Raghav.
0
 
Dan McFaddenSystems EngineerCommented:
Do not change the ports in IIS.  If you have only 1 IP on the server, you need to be utilizing Host Names on all site bindings in IIS.

Can you post a view of the site running on your server?

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
The site is not running due to port is blocked by system pid '4'.
0
 
Dan McFaddenSystems EngineerCommented:
And what is the process name of PID 4?

Have you opened the necessary ports on the Windows Firewall?

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
System.

Yes ports are open and are in listening mode.
0
 
Dan McFaddenSystems EngineerCommented:
OK, again I'll ask... can you post a screen shot from IIS Manager, of the sites running on your server?  A shot of the all the site... please just select the Sites node in the left navigation, you will see a list off everything running in the center console.

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Hi Dan McFadden,

Please find the Sites node screenshot.

Sites Node
Regards,
D Patel
0
All Courses

From novice to tech pro — start learning today.