Error DNS: DNS servers on NIC1 should include the loopback address, but not as the first entry.

Good experts, I am running Windows Server 2012 R2 and I decided to run the BPA built into the operating system.  The (TITLE) explains what the error is in fact I did at the loopback address as the second DNS but still the error is there.  What can I do to get rid of the error from showing up again?  Thanks
PowerC280Asked:
Who is Participating?
 
Dan McFaddenConnect With a Mentor Systems EngineerCommented:
In DNS Manager, configure the DNS Service to use the "Only the following" option and choose the server's internal IP  Then restart the DNS Service.

On the DC's TCP/IP config, only enter a single IP in the server's DNS config.

In DNS manager, having the server twice is due to you having added it twice.  Choose one to use and delete the other.

Dan
0
 
Dan McFaddenSystems EngineerCommented:
The BPA is not giving the best of remediation advice.  The sort of defacto How-To article on how to setup your DC/DNS server TCP/IP configuration is the article link below.

Link:  https://abhijitw.wordpress.com/2012/03/03/best-practices-for-dns-client-settings-on-domain-controller/

Unless you only have a single DC/DNS server in your org, I would not recommend using 127.0.0.1 as a DNS server.

- How many DC/DNS servers do you have in production?
- How is/are the IPs bound to the DNS Service in DNS Manager?
---- Listen on:  "All IP addresses" or on "Only the following..."
* In DNS Manager, properties on the DNS Server, view the Interfaces tab *

Dan
0
 
PowerC280Author Commented:
- How many DC/DNS servers do you have in production?,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, (1)
- How is/are the IPs bound to the DNS Service in DNS Manager?,,,,,,,,,,,,,,,,,,,,,,, ( All IP Addresses)
---- Listen on:  "All IP addresses" or on "Only the following..."
* In DNS Manager, properties on the DNS Server, view the Interfaces tab *,,, (Only 1 IP address listed)

Also in the DNS Manager I have 2 DNS's one that says (ABCD and the other ABCD.domain.local)  what is this all about.

Thanks
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
PowerC280Author Commented:
YOU SAID: In DNS manager, having the server twice is due to you having added it twice.  Choose one to use and delete the other.  No, I did not enter DNS in twice only once.  I went through my usual steps setting my server up.  I am noticing that 2 of the server I did setup has 2 DNS's.  

Which one do I get rid of the one with .local or without .local???
0
 
Dan McFaddenSystems EngineerCommented:
I would just delete all the servers in the server list and add the DNS Server with its FQDN.  Honestly, it doesn't make a difference to use the FQDN or just the hostname... which ever you prefer more.

Dan
0
 
PowerC280Author Commented:
This was the best solution for me when it came down to removing one of the DNS entries.   On adding the 127.0.0.1 as second DNS...i removed completely which it did not fix the issue but I ended up excluding the issue.  Thanks Dan

Ben
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.