WINDOWS 7 640-bit failes to install on dell optiplex 380

HI EXPERTS,

 I'm installing windows 7 from a DVD. I boot from the DVD and click Install Windows then I get the error:

  Load Driver:
     A required CD/DVD  drive device driver is missing. if you have a driver floppy disk, CD. DVD, or USB flash drive , please insert it now.
   Note: if the windows installation media is in the CD/DVD drive, you can safely remove it for this step.

and that's it! I thought it was my DVD so I burned a new one and same results.

 please help!
frankbustosAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
rindiConnect With a Mentor Commented:
Are you installing from an internal DVD drive, or is it connected via USB? If USB, is it connected to a USB 3 or USB 2 port?

Never use a USB 3 port when installing Windows, USB 3 drivers are missing in the OS. Also don't change to compatible mode for the disk controller in the BIOS. The OS will work best when using AHCI mode. If you install it in compatible mode you can't easily change back to AHCI mode after installation, as those drivers won't be installed. You'll get a BSOD.

Also, rather than using a DVD, I'd suggest installing the OS via a bootable USB stick. It is faster and works better. You can use the WinSetupFromUSB utility to create the stick from the iso file. Remember to use a USB2 port when installing:

http://www.winsetupfromusb.com/files/download-info/winsetupfromusb-1-7-exe/
0
 
JohnBusiness Consultant (Owner)Commented:
Try setting AHCI to Compatibility Mode in the BIOS, then restart and try again. This setting may help you install. You can always change it back.
0
 
frankbustosAuthor Commented:
John,

 i'm unable to find the AHCI in the bios. it's under drives right?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
JohnBusiness Consultant (Owner)Commented:
It should be on the system settings.
0
 
JohnBusiness Consultant (Owner)Commented:
I also read an accepted solution in another forum that says set DVD first in the BIOS and hard drive second. There may not be an AHCI setting in Dell BIOS. Try the boot order (change it).
0
 
frankbustosAuthor Commented:
John same results, could it be that the system is  not compatible with 64-bit? maybe a bad image but i've tried multiple ISO images of windows.
0
 
JohnBusiness Consultant (Owner)Commented:
Yes it looks like a compatibility problem of some sort. Can you try a different DVD device?  

Can you put the image on a USB key and boot from that?
0
 
rindiCommented:
You are using a core 2 duo CPU. Those are 64 bit. Only Core Duo and older CPU's are 32bit only. Besides that, you'd get another error message if the CPU wasn't the proper CPU. It is more likely your DVD drive is bad (if it is internal), or connected to a USB 3 port if external.

As I suggested, try a USB stick rather than a DVD.
0
 
frankbustosAuthor Commented:
Thank you Rindi, I did the USB and it worked super well and FAST!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.