[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Help on fixing clipboard in Remote Desktop under Windows 10 connected to Windows Server 2008

Posted on 2016-11-01
14
Medium Priority
?
90 Views
Last Modified: 2016-11-06
We are working via Remote Desktop with our Windows 10 Pro PC connected to Windows Server 2008 R2 Stabdard.  The problem we face is that what we copy to our local clipboard, does copy to our remote server clipboard.  Yet if we connect to local VM or local computer the clipboard works.

What we have done so far:

In our computer:
taskkill.exe /F /IM rdpclip.exe
rdpclip.exe


In the remote server:
Set disabled "Do not allow clipboard redirection" Console (mmc)

Please advice what else to do.
0
Comment
Question by:rayluvs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 3
14 Comments
 
LVL 71

Expert Comment

by:Qlemo
ID: 41868232
I'm not clear about what you really want to do (and how a VM comes into play here). You do not want to use the clipboard for RDP?
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 41868261
You say both work. Is there an issue?
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 41868263
Also if you are trying to copy between host and guest, you would need something like VMware Tools installed.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:rayluvs
ID: 41868273
"I'm not clear about what you really want to do (and how a VM comes into play here). You do not want to use the clipboard for RDP?"

We want to copy from our local PC and paste at the server via RDP
VM is only to inform that RDP works under other connections.
Yes we do want to use clipboard for RDP

"You say both work. Is there an issue?"
"Also if you are trying to copy between host and guest, you would need something like VMware Tools installed."

The issue is that we cannot copy from our local PC and past to a remote server.
We are trying to copy guest (PC) to host (Server).
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 41868275
Do you have the equivalent of Tools installed. You need to do this to copy between guest and host.
0
 

Author Comment

by:rayluvs
ID: 41868290
Yes, as our question indicates " Yet if we connect to local VM or local computer the clipboard works".  That is, we are currently using RDP to work with VMs and other computers within the office and clipboard works fine.

The problem occurs working with the server.
0
 

Accepted Solution

by:
rayluvs earned 0 total points
ID: 41868304
Found the solution.  So for future members with the problem, here are the steps we did to successful copy from a local PC to a Remote computer as per our problem:

  • Run >> mmc
  • File menu >> Add/Remove Snap-in.
  • Click Group Policy Object under Available Stand-alone Snap-ins.
  • Click Add >> Finish >> Ok.
  • Left panel >> Local Computer Policy\Computer Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Device and Resource Redirection".
  • Select "Do not allow clipboard redirection" .
  • Right click >> Edit and select "disabled".
  • Do the same for User Configuration (left panel).
  • Finally, restart the server (the part we didn't do)

Note, even though in our question we already said we did "Do not allow clipboard redirection", we didn't do the User part nor the restart.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 41868314
The default for RDP is to allow Clipboard Redirection. You are overriding something set elsewhere, hence.
0
 

Author Comment

by:rayluvs
ID: 41868322
... it wasn't as default in Windows Server so we set it; worked!
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 41868497
"not set" doesn't mean "active" in any way - neither off nor on. The setting is either derived from lower priority GPOs, or by the system default - which is "enabled" (GPO "off").
0
 

Author Comment

by:rayluvs
ID: 41868561
What we meant was that we set it to disabled and it worked.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 41868574
That's clear. I just try to tell the issue results from somewhere else, and you might want to look for that (or leave as-is, which works for you).
0
 

Author Comment

by:rayluvs
ID: 41868861
Thanx
0
 

Author Closing Comment

by:rayluvs
ID: 41876016
We chose our question since ot solved our specific Local PC to Remote Windows Server 2008 RDP connection.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question