Mac OS reinstall process and move to SSD

I want to have a clean start with a Mac Mini (late 2012) that has Yosemite right now. At the same time, I want to delete the existing Apple ID associated to the machine. What is the best way? I would like to keep Yosemite, but maybe it is not possible. I did not see anything in App store, and I don't know what OS version it originally had.

What I have done so far:
Opened the case and ready to put SSD
Ran Time Machine to backup to external USB drive

It sounds that somewhere I need to de-authorize the computer from iTune.
And I have a feeling that I need to make a USB bootable to install the latest Sierra from scratch onto SSD.

If all of this is very time consuming, then I could just upgrade the OS to the Sierra, and transfer all to SSD. I am a Windows guy, and I am used to reinstalling Windows OS every 3-5 years, to speed it up. How does Mac work? Upgrading to the latest Mac OS would give it a fresh start?

Lastly, if something goes wrong, can I restore all from the external USB drive? I don't even know what format it is in. I just did a few clicks to make it available for Time Machine.
Who is Participating?
Adelaido JimenezConnect With a Mentor DevOpsCommented:
The time machine is like a windows backup. If any thing goes wrong than you can restore your machine using the Time Machine sparse file that was created in your external hard drive. It is really easy to restore from Time Machine backup. You would just to the recovery window and select boot from Time Machine and everything should be restore to its original state. If you want to start fresh I would suggest taking the Time Machine backup to backup all of you data first. I would then download the New OSX Sierra and create a bootable USB or CD with the  new OSX. I would then boot to the recovery window and format my drive and then boot to the USB to install the new OSX. This will give me a clean install on the Mac and should be able to associate a new apple id
Before you take out the old drive, put the new drive into a USB case. Then use Carbon Copy Cloner  to clone the old drive to the new one. Then swap drives. All done.
Member_2_7970390Author Commented:
I could not de-authorize Mac in iTune before reinstalling the OS.
Can I reinstall the new OS without de-authorizing the computer first, and still be OK after reinstallation?

What can I do since I have no idea about what Apple ID was originally associated? How can I proceed?

I could not even create a new apple id. It said, "Session timed out. Try again later." Therefore I cannot even download Sierra.
The new generation of project management tools

With’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Adelaido JimenezConnect With a Mentor DevOpsCommented:
You can actually reinstall the OS without de-authorizing, but keep in mind that if you don’t, your single computer may count as a different computer afterwards and use multiple authorizations.
Deauthorizing a computer is important because it gives you one of your limited five authorizations back. When you authorize a machine on itunes it just gives the machine access to the purchased content you've bought with that itunes account. Since you don't know what account was used and don't care about any purchases you've made through that account you can just reinstall the OS without de-authorizing it. You can sign in to the app store NOT itunes and download the new OSX with an apple ID you know the credentials to.
Member_2_7970390Author Commented:
Finally I was able to make a USB bootable flash drive, and installed a brand new Sandisk SSD.
When it was boot up from the USB, it did not recognize the SSD. Does that mean I have to format SSD for Mac to recognize it?

Could I format it in Linux or something? I have a very old laptop that has Linux.
strungConnect With a Mentor Commented:
When booted from the USB flash drive, go to Disk Utility and use it to format the SSD as Apple Extended Format (Journalled). Click on the Partition tab and make sure the partition map is set to GUID, not MBR. If it is not GUID, click on the options button to set it to GUID.
Member_2_7970390Author Commented:
Thank you guys, everything went well, except one error:
ServiceRecords cannot be opened because of a problem. Check with the developer to make sure ServiceRecords works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.

I am not even sure what app is causing this.
strungConnect With a Mentor Commented:
Servicerecords appears to be Citrix software. Are you running a Citrix VPN?
Adelaido JimenezDevOpsCommented:
Some application might not be compatible with the new OSX, and will require a reinstall. I've notice this when I upgraded to the new OSX and my anti virus started complaining that the application was not compatible and that I should visit the vendors site. I reinstalled the anti virus and everything worked just fine. I would visit the vendors site and download the latest version for the application/software you are using.
Member_2_7970390Author Commented:
I saw the app "Citrix Receiver," which I don't know anything about. So I put in the recycle bin, without permanently deleting it, yet I still get the error. I am afraid to delete it without knowing what it is. Please advise.

Here is the detailed error:

Process:               ServiceRecords [1384]
Path:                  /usr/local/libexec/
Identifier:            ServiceRecords
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           ServiceRecords [1384]
User ID:               505

Date/Time:             2016-11-08 11:23:17.913 -0500
OS Version:            Mac OS X 10.12.1 (16B2657)
Report Version:        12
Anonymous UUID:        58C38CDA-AF3B-3BD1-5932-05311F8FFE7B

Sleep/Wake UUID:       CC4B48F6-765F-43C3-81AB-A5261835F1D0

Time Awake Since Boot: 5700 seconds
Time Since Wake:       45 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/libxerces-c-3.1.dylib
  Referenced from: /usr/local/libexec/
  Reason: no suitable image found.  Did find:
      /usr/local/libexec/ unknown file type, first eight bytes: 0xE0 0xFB 0xC1 0x98 0x83 0xDA 0x34 0x40

Binary Images:
       0x100000000 -        0x10003afff +ServiceRecords (???) <57BC298A-6A13-38AD-BB78-83B2F66398D1> /usr/local/libexec/
       0x103d7f000 -        0x103dbc287  dyld (421.2) <F5F79617-5669-3424-A2CF-18B23BB0C0C7> /usr/lib/dyld
    0x7fff77eef000 -     0x7fff77eeffff (6.11 - 22) <5EEB0A26-F1C2-3D57-8441-52C0B80C2A6A> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x7fff7e77a000 -     0x7fff7ea96ff7 (7.0 - 57740.20.22) <B3CE2460-305A-393B-8B84-B58B1A5B2CA7> /System/Library/Frameworks/Security.framework/Versions/A/Security
    0x7fff7eebf000 -     0x7fff7ef30ff7 (1.14 - 1.14) <013957CA-2708-31F0-845D-11E271C96B94> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration

Model: Macmini6,2, BootROM MM61.0106.B0A, 4 processors, Intel Core i7, 2.3 GHz, 16 GB, SMC 2.8f0
[the rest is about my model]
Citrix receiver is a VPN application. Typically it would be used to access a work computer or server from home. If you don't do anything like that, you don't need it, although how it got on your computer is a puzzle.

If you don't need it, you should remove it with an uninstaller. If you do need it you should update it.

In either case, if you download Citrix Receiver from here: the downloaded file will include both the most recent version and an uninstaller so you can take your pick as to whether to update or uninstall.
Member_2_7970390Author Commented:
Used uninstaller, and no more error message. Victory!!!
Thank you so much. It is all taken care of.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.