Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 81
  • Last Modified:

OWA https link works internally but not working externally - shows 404 page not found error.

I have exchange 2003 with SP2 running on windows 2003 server and IIS6.

Internally:

I get https://myemailserver/exchange to work and it goes to the certificate warning page and then to the login page.


Externally:

But when I goto https://mail.mydomain.com/exchange externally (outside the domain) it goes to a 404 page not found error.


Please note: http://mail.mydomain.com/exchange works just fine externally and http://myemailserver/exchange work just fine internally without any issues.
0
IT_Field_Technician
Asked:
IT_Field_Technician
  • 7
1 Solution
 
Thomas WheelerCommented:
are you using NAT on the inside? Is your source NAT rules set properly to allow access to the external URLS for internal users?
0
 
IT_Field_TechnicianAuthor Commented:
Hi Thomas how do I determine if I am using NAT on the inside - do you mean on my firewall?

If so yes I am using NAT on the inside on my firewall. I have reviewed my firewall config and my http and https NAT is configured properly and pointed to my exchange server IP address for port 443  and port 80.

Any other ideas?
0
 
IT_Field_TechnicianAuthor Commented:
could this be the reason Why OWA is not accessible externally on https?

because the self signed certificate has expired?

q
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
IT_Field_TechnicianAuthor Commented:
I am also noticing that this is not checked - If this is not checked then how am I able to get to https://localhost/exchange INTERNALLY and log in without a problem?

t
0
 
IT_Field_TechnicianAuthor Commented:
I just found this but this is not the error I am getting this article describes error 403.4 Forbidden page:

https://support.microsoft.com/en-us/kb/839357

where as I am getting:


The webpage cannot be found
 
  HTTP 404


1214.png
0
 
IT_Field_TechnicianAuthor Commented:
Is anyone there?
0
 
IT_Field_TechnicianAuthor Commented:
Nevermind - I answered my own questions - I actually caused the issue by deploying SSL VPN on my watchguard firewall- Even though my https proxy (which was using incoming port 443) for OWA access was above the SSL VPN policy in priority the SSL VPN policy overrode it for some reason and when I disabled the SSL VPN policy that I just created the other day I was able to get to httpS://mail.mydomain.com/exchange.

Thanks for everything!
0
 
IT_Field_TechnicianAuthor Commented:
thanks
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now