Solved

SSRS printing

Posted on 2016-11-03
3
63 Views
Last Modified: 2016-11-17
I see our reports with say one page, yet when it prints it prints two pages, the second page is just the header. How can we fix that ?
0
Comment
Question by:basile
3 Comments
 
LVL 12

Accepted Solution

by:
Nakul Vachhrajani earned 167 total points
ID: 41872278
Can you check the report definition?

There are properties on the report definition (PageHeight & PageWidth) that you can set based on your paper size to give you an idea of how much you can fit into a page.

Basically, you need to ensure that the report body width plus the margins should be less than the defined page width.

Some things to work around this are: If your UI elements (tablix, etc) are enclosed in a Rectangle, check the PageBreakAtStart and PageBreakAtEnd properties of the rectangle.

Check for items growing horizontally via the "Autosize" or "AutoFit" properties (e.g. matrix data regions and images placed in the body).

Also, ensure that you do not have any explicit page breaks defined on the report definition.
0
 
LVL 28

Assisted Solution

by:Pawan Kumar
Pawan Kumar earned 167 total points
ID: 41872583
Try..

The margins have to be the right size. Ex-

Page = 8.5 x 11.....    Right and left margin .5" equals one inch. so the table or body of the report has to be smaller than 7.5" wide.

Also check on your table cells to see if the Text Box data is growing to much.
0
 
LVL 14

Assisted Solution

by:Megan Brooks
Megan Brooks earned 166 total points
ID: 41872866
If you are using Report Designer, it is forever taking valid report definitions and widening the report body for one reason or another, automatically while you work, so that when you later render to PDF, extra page breaks are introduced. Before you check in changes, you need to make sure that the body width is correct.

There are other possible causes, as noted, but nearly every report I have had to fix because of extra pages in PDF output has had a body with excess width.

Also, don't forget to try setting ConsumeContainerWhitespace to True in the report properties if you are seeing blank pages at the end. It's False by default and, as far as I can tell from the documentation, setting it to the default means "introduce an extra page break at the end of PDF output, sometimes." I'm not sure if this is a useful feature or not, but there it is. It was added in RS 2008, and I have never run into a problem just turning it on, always. If you work from a template, turn it on in the template.
1

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Everyone has problem when going to load data into Data warehouse (EDW). They all need to confirm that data quality is good but they don't no how to proceed. Microsoft has provided new task within SSIS 2008 called "Data Profiler Task". It solve th…
The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question