• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 99
  • Last Modified:

Internal sites require http:

I have setup an internal DNS with GlobalNames Zone. I have a DNS name pointing to an internal IP.

For example: education.domain.com points to 192.168.0.25

When I go to a web browser and type in http://education it will bring me to the website. What I would like is to be able not to type in the http://

So I just type in education and it auto fills to the IP address. This has been setup at another company I worked for but unsure how it was setup.
0
Chris Nelson
Asked:
Chris Nelson
  • 3
  • 3
  • 2
2 Solutions
 
pony10usCommented:
Put an alias in your DNS for education that points to the same ip address as education.domain.com, 192.168.0.25
0
 
Chris NelsonAuthor Commented:
Inside my GlobalNames I have already setup an Alias (CNAME) pointing to the IP address.
0
 
footechCommented:
If http://education already brings you to the site, then you're all set with DNS.
The http:// portion only specifies the protocol to use, and it's up to the application to determine what to do when the user doesn't supply it.  If you type in "education" in IE for example, it takes me to a Google page (cause that's what I have set as the search engine) and then at the bottom, there's a little popup that says, "Did you want to go to 'http://education'? Yes No".

You would have to research whether there's a setting to modify the behavior for whatever browsers you're using.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Chris NelsonAuthor Commented:
@footech

I was afraid you were going to say that. I wasn't sure if it was a DNS issue or browser issue. I've been trying to search for it and am unable to find a solution thus far. The browsers we are using are:

IE 11
Firefox
Chrome

If I can get it to work on any of them I'd be happy. Probably IE 11 since its the most basic and then I can tell users to use IE 11 to use the shortcut search. But any help you or anyone else could provide in finding a solution would be great.
0
 
pony10usCommented:
footech is correct, as usual :)

There are a couple of things that could cause this.  However I would start by looking at the registry entrys:  

LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes

*** BACKUP THE REGISTRY PRIOR TO MAKING CHANGES ***
0
 
pony10usCommented:
sorry I duplicated the entry.  

reg setting
0
 
Chris NelsonAuthor Commented:
I got it to work in IE 11

https://support.microsoft.com/en-us/kb/2411821

Now I just need to try in Firefox and Chrome
0
 
footechCommented:
Nice.

Sorry I don't have time to look into the browsers behavior.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now