Solved

Run-time error - atibtmon.exe

Posted on 2016-11-06
31
56 Views
Last Modified: 2016-11-22
Hello,
A clients computer was updated to Windows 10. She began getting a popup message "atibtmon.exe Run-time error". I adjusted ATI Graphics Power Options (after doing research) to resolve atibtmon.exe run-time error which seems to help. But it has begun again, especially when she is in Facebook or looking at YouTube videos.  I don't know where to go next.

Your help, as always, is appreciated,
Mags
0
Comment
Question by:MagsMcKinley14
  • 18
  • 12
31 Comments
 
LVL 53

Expert Comment

by:McKnife
ID: 41876333
Try and uninstall the Ati software completely. Then download the latest version and install it.
1
 

Author Comment

by:MagsMcKinley14
ID: 41876337
Thanks McKnife. I will do that as soon as I can access her computer!
0
 
LVL 23

Expert Comment

by:Dr. Klahn
ID: 41876352
Side note:  I uninstalled all the ATI Catalyst, etc. software on my system accidentally a few weeks back and never noticed it.  Everything still works.
1
 

Author Comment

by:MagsMcKinley14
ID: 41880899
Okay I uninstalled the ATI Catalyst Install Manager. The ATI Mobility Radeon HD 4200 Series says it is using the best driver. She is still getting the popup. I found this...would you suggest trying this -

You need to uninstall your previous AMD Control centre (Remove everything) and restart your computer (which I did), and then install the windows 7/8 AMD legacy driver (AMD Catalyst 13.4 Legacy Driver) under compatibility mode windows 8 with administrative rights (Right click on setup and select TROUBLESHOOT compatibility THEN SELECT TROUBLESHOOT PROGRAM, THEN SELECT THE PROGRAM WORKED IN EARLIER VERSIONS, THEN SELECT Windows 8, COMPLETE COMPATIBILITY MODE), this will then give you partial Catalyst control centre. You then need to go to Device manager and manually force install the legacy display driver which did not install using setup. Double click on Ati display driver choose driver tab, select update driver, select 'browse my computer' for driver, then select 'Let me pick from list' click on have disk, and browse to your driver directory C:\AMD\AMD_Catalyst_13.4_Legacy_Beta_Vista_Win7_Win8\Packages\Drivers\Display. And select the FOLDER  W8_inf, this will then install the legacy driver correctly, and give you full functionality of the Legacy driver. This driver works fine with no issues detected so far, even the app market works fine.

If not, other suggestions?
Thank you!
0
 
LVL 53

Accepted Solution

by:
McKnife earned 500 total points
ID: 41881070
You will only need the driver. uninstall all AMD/ATI components, check with msconfig&task manager that no startup items are left. Download the driver and install just that, no control centers nor any other customer retention crap.
If it still comes, use autoruns to locate that very startup item. You could also do that right now.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881096
I'm not seeing just a driver download on their site.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881119
Okay...doing a custom install...not allowing to uncheck the Catalyst Install Manager...doing the best I can.
0
 
LVL 53

Expert Comment

by:McKnife
ID: 41881201
That's it, the custom installation.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881209
Crossing my fingers...couldn't simply install only the drivers but installed in compatibility mode then pointed to the downloaded drivers. She is testing now. Thanks McKnife.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881218
So far so good...she put it through the ringer. I will close out in a day or so to see if the pesky error pops up.
Thanks,
Mags
0
 

Author Comment

by:MagsMcKinley14
ID: 41881232
Didn't work. Help!!
0
 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 500 total points
ID: 41881248
1 download autoruns.exe from microsoft and launch via right clicking it, selecting "run as administrator"
2 with that tool, search for atibtmon.exe, you'll be able to uncheck (=deactivate) it with it.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881299
I'm not finding it in Autoruns, I even did a search. I do see atibtmon.exe in c:\WINDOWS\System32\
One suggestion is to uninstall it by renaming it to _atibtmon.exe and rebooting??
0
 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 500 total points
ID: 41881316
In autooruns, switch to the "all items" tab. There, search for it or for related things from ATI or AMD. There will be things to deactivate. Renaming it would only lead to another error message.
0
 

Author Comment

by:MagsMcKinley14
ID: 41881413
Okay...I have unchecked all things related to ATI and AMD, should any of them be deleted? Crossing my fingers! Also uninstalled the AMD Catalyst Install Manager that came with the driver re-install.
Mags
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 500 total points
ID: 41881917
No, don't delete anything or you will not be able to undo it if needed.
If you don't know what autoruns is showing: these items are autostart items, scheduled tasks and services but also drivers! So you can imagine, if you uncheck the drivers, they will no longer work. You need to skip unchecking the items from the driver section.
0
 

Author Comment

by:MagsMcKinley14
ID: 41882164
Ok...I will go back and review everything, I misunderstood, I thought I was asked to uncheck everything in autoruns that contained ATI or AMD, I did not delete anything in Autoruns.  She informed me her graphics looked off. Will I be using the Microsoft or AMD graphics drivers or see which looks best?

I appreciate your assistance, I learn so much from all of you!
0
 
LVL 53

Expert Comment

by:McKnife
ID: 41882471
Microsoft has only generic drivers for this card, those offer no performance, nor screen extending.
1
 

Author Comment

by:MagsMcKinley14
ID: 41884168
McKnife...her screen is back to normal. She will test her computer by opening up various videos to see if she continues to get the error message. Thank you for your assistance...I will be in touch!
Mags
0
 

Author Comment

by:MagsMcKinley14
ID: 41885658
Okay...she is still getting the popup. What next?
Thanks,
Mags
0
 
LVL 53

Expert Comment

by:McKnife
ID: 41885673
Reopen autoruns. Autoruns can save its output, simply press the disk icon and then upload the file here so I can analyse it.
0
 

Author Comment

by:MagsMcKinley14
ID: 41885706
Thanks, I will see if she can leave her computer on for me tomorrow and I will send it to you.
0
 

Author Comment

by:MagsMcKinley14
ID: 41886400
Okay here is the Autoruns report and a copy of the exact error message.
Thanks again for your help!
Mags
SANDRA-PC.arn
atibtmon.exe-error-message.jpeg
0
 
LVL 53

Expert Comment

by:McKnife
ID: 41886411
Hmmm, my autoruns tells me, that file is corrupt. Please download the latest autoruns (if you don't already use v13.62) and recreate it and upload it again.
0
 

Author Comment

by:MagsMcKinley14
ID: 41886767
I am using that version...here is a new saved file. I was able to open it on my computer and it is much larger than the last.
SANDRA-PC-2.arn
0
 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 500 total points
ID: 41886784
Ok, that one works.
Looked at it and noticed that there are many many AMD and ATI entries that are not unchecked - but I had told you to go through the sections and uncheck the ATI/AMD stuff, while skipping just then entries on the drivers tab. Please do that.
0
 

Author Comment

by:MagsMcKinley14
ID: 41886796
I went through it with a fine tooth comb and am only finding the ones checked under Drivers (HKLM\System\CurrentControSet\Services).
Are those the ones you are seeing...If not please send me the file name. Thank you.
0
 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 500 total points
ID: 41886808
Sorry, I have to say my eyes are tired and there were not "many many" but in fact just one:
Services section:
AMD External Events Utility      AMD External Events Service Module      AMD      c:\windows\system32\atiesrxx.exe      1/13/2015 5:40 PM      
->uncheck that one and reboot.
--
The rest that I had seen were inside the drivers section after all.
0
 

Author Comment

by:MagsMcKinley14
ID: 41886819
Wow...how did I miss that one...pretty easy to see. ;-) Thanks! It's under services...hopefully that is the culprit!
0
 

Author Closing Comment

by:MagsMcKinley14
ID: 41898079
Thanks McKnife...still no pop up! I appreciate all your patient help!!
Mags
0
 
LVL 53

Expert Comment

by:McKnife
ID: 41898158
Hey, glad for you!
1

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
OfficeMate Freezes on login or does not load after login credentials are input.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now