Solved

Help with permissions Windows User Account Control (UAC)

Posted on 2016-11-07
18
24 Views
Last Modified: 2016-11-12
I've tried so many things up to now.
I'm trying to solve : "Verify that sufficient permissions have been granted and Windows User Account Control (UAC)" on my local report server. I'm unable to see the Home folder to grant permissions, when clicking the "Home" link, nothing happens
0
Comment
Question by:fadiel ras
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
  • 2
18 Comments
 
LVL 13

Expert Comment

by:Nakul Vachhrajani
ID: 41876972
Try running the browser as "Administrator" (Right-click -> Run as Administrator).

Once the Report Manager is up, add your login on the site and on folder settings and give "System Administrator" permissions. You should be all set.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41876974
Are you on a domain?   Go to Network and Sharing Center, Advanced Sharing properties and ensure the network is attached to Private or Domain. Ensure the Home Group is definitely OFF.

Try temporarily disabling your Firewall, restart and test.
0
 

Author Comment

by:fadiel ras
ID: 41876975
thanks Nakul. I've done that. problem is that I dont see the site settings option. when I click "Home" previously on other machines I would get the Root folder with DataSources, Setting etc. In this case, nothing happens
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:fadiel ras
ID: 41876977
Thanks John. yes on a Domain, but trying to access Localhost. I'll try and advise asap...
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41876979
Also check that no extra entries exist in local HOSTS file (C:\windows\system32\drivers\etc.)
The entries in the HOSTS file should be all comments.

Run a full scan with your Antivirus application.
0
 

Author Comment

by:fadiel ras
ID: 41876981
@John, please clarify >>Ensure the Home Group is definitely OFF.
should I turn it off, then also disable the firewall?
then start IS as an admin?
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41876986
Home Group is down at the bottom of the Advanced Settings. There is a choice between (a) Use User accounts and passwords and (b) Home Group. Select User Accounts and Passwords. Make sure the User Account has a password.

Try the above before temporarily disabling the firewall
1
 

Author Comment

by:fadiel ras
ID: 41876987
@John - no idea what you mean with this >>Also check that no extra entries exist in local HOSTS file (C:\windows\system32\drivers\etc.)
The entries in the HOSTS file should be all comments.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41876989
Navigate to the folder above and open HOSTS with Notepad.
0
 
LVL 13

Expert Comment

by:Nakul Vachhrajani
ID: 41876990
Since you don't get the Site Settings option, can you confirm that you are a sysadmin on the SQL Server instance where the ReportServer database is hosted?
0
 

Author Comment

by:fadiel ras
ID: 41876991
@Nakul, yes I am, but will double check. this is fresh installation of SQL2014 Express on this machine
0
 

Author Comment

by:fadiel ras
ID: 41876998
@John, this  what I see in advanced settings, Homegroup
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41877002
Turn Home Group OFF by selecting Use user accounts and passwords. It is a choice, so selecting Use user accounts will turn Home Group OFF.  Home Group is not for use on domains.

Once OFF, you might consider disjoining from and rejoining back to the Domain.
1
 

Author Comment

by:fadiel ras
ID: 41877020
@Nakal - "Current user's login is a member of the sysadmin role"
0
 

Author Comment

by:fadiel ras
ID: 41877060
I'm now busy testing this, as I realized I had 2 problems, 1. being the settings issue, but 2. being that I'm prompted to log in when I launch the report server, I think that might be the root cause of my issue
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 41877064
Test your ideas and then report back. Make sure your login is authorized.
0
 

Accepted Solution

by:
fadiel ras earned 0 total points
ID: 41877245
Solved. Thanks John and Nakal for your prompt responses.
my solution was in the marked answer section here: https://social.msdn.microsoft.com/Forums/sqlserver/en-US/e8da121a-c0ac-4d0b-8774-abd5128d88fe/ssrs-2008-vista-security-header-only?forum=sqlreportingservices

Issue
When you browse to http://[ComputerName]/Reports it prompts you to login
 
Cause
This is caused by UAC.  Even if you run Internet Explorer as Administrator, once you log in you are no longer running with administrative privileges.

1.     Open Internet Explorer
2.     Click on the "Tools" menu and select "Internet Options"
3.     Click on the "Security" tab
4.     Click once on "Local intranet"
5.     Click on the "Sites" button
6.     Click on the "Advanced" button
7.     Make sure "Require server verification (https:) for all sites in this zone is unchecked.
8.     Add "http://[ ComputerName]" to the Websites list.
9.     Click the "Close" button to close the Advanced window.
10.   Click the “Custom Level” button near the bottom.
11.   Scroll down to the end and you will see the “User Authentication” section.
12.   User “User Authentication” and then “Logon” verify that “Automatic logon only in Intranet Zone” is selected.  If not select it.
13.   Click “OK” to close the Security Settings - Local Intranet Zone window.
14.   Click the "OK" button to close the Local intranet window.
15.   Click the "OK" button to close the Internet Options Window
16.   Close Internet Explorer
17.   Re-open Internet Explorer and browse to http://[ ComputerName]/Reports.  You should no longer be prompted to login.
0
 

Author Closing Comment

by:fadiel ras
ID: 41884562
found on another thread
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A recent questions about how to add SSRS named instances, couldn't find any that talks about SQL server 2008, anyway I decided to help by creating some screen shots. The installation is straightforward, you just pop the SQL server 2008 installati…
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question