Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Trying to make SNMP connection work

Posted on 2016-11-08
7
Medium Priority
?
172 Views
Last Modified: 2016-11-22
Hello,

I am trying to get the Dell Troubleshooting Tool for OSMA to connect correctly to openSUSE systems via SNMP.  The error I am receiving is:

The SNMP read request has failed for Get Community name - this-domain

I cannot figure out where to change the community name on the SUSE system.

Please advise.

Thank you,

Don
0
Comment
Question by:GEMCC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 12

Accepted Solution

by:
Kent W earned 1000 total points
ID: 41879466
If you have installed net-snmp-utils (which installs the snmp daemon 'snmpd', the config file is under /etc/snmp/snmpd.conf
The line you are looking for is
rocommunity public
Change "public" to whatever you want the ro community, restart snmpd.

If you have not installed net-snmp-utils, you can do so with the command
zypper install net-snmp-utils
1
 

Author Comment

by:GEMCC
ID: 41879511
I have net-snmp installed.  When I try to install net-snmp-utils I receive the error:

Package 'net-snmp-utils' not found
0
 
LVL 12

Expert Comment

by:Kent W
ID: 41879531
I don't have a SUSE box here to test directly, but I do believe net-snmp includes the -utils and phyton, from what I"m seeing.

Do you have a service named "snmpd" and an snmpd.conf? Usually found under /etc/snmp/snmpd.conf
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:GEMCC
ID: 41879539
Yes and I set rocommunity to the proper name, but it is still not working.
0
 
LVL 12

Assisted Solution

by:Kent W
Kent W earned 1000 total points
ID: 41879563
Are you getting the same read request error? And you did restart the snmpd service to re-read the config, right? (Sometimes it's the little things...)

DO you have a firewall blocking ports 161-162?
0
 
LVL 80

Assisted Solution

by:arnold
arnold earned 1000 total points
ID: 41879875
Can you locally poll?
snmpwalk -v2c -c communityname localhost?

If that provides you a response, this means you have a software firewall blocking access to udp/TCP port 161
Open the port on the software firewall.
0
 

Author Closing Comment

by:GEMCC
ID: 41881025
I had the rocommunity set at name 127.0.0.1.  Set to name only then it worked!  Thank you!
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question