Apple computer tries to connect to WLAN?

I have an iMac.  The O.S. is El Capitain.  I have it wirelessly connected to our router with an encrypted SSID.  It keeps periodically connecting on its own to an unprotected network called WLAN.  When I get a notification that it has done this I immediately switch it over the our encrypted SSID.  Why is it doing this and how can I prevent this from happening...it is a real nuisance.
thanks,
capreol
capreolAsked:
Who is Participating?
 
strungCommented:
System Preferences > Network > Wifi

If necessary, click on the lock button at the lower left to unlock it.

Check "Ask to Join Networks".

Then click on the Advanced button, then the Wifi button. Click on WLAN in the list, then on the minus button to delete it.
0
 
capreolAuthor Commented:
Excellent answer.  Thanks very much.
capreol
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.