?
Solved

Microsoft Outlook Global Address List Not Working

Posted on 2016-11-09
6
Medium Priority
?
83 Views
Last Modified: 2016-11-19
Dear All,


We are encountering an issue where users with cached mode enabled are not defaulting to Global Address List when they click on check names.

We have already check the settings and the address lists has Global Address List first in the order and also the radio button start with Global Address List is selected.

Image of Address book settings
Even though these settings have been set whenever the users with Cached Mode Enabled click Check Names they default to another address book that is local to the machine, or another one from the list of address books provided.

Does anyone have any idea what this might be and how it should be fixed.

Thanks in Advance.
0
Comment
Question by:casscar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 3

Expert Comment

by:Adiel de Freitas
ID: 41881287
I think this might be the Mail Profile.
You can test this by creating a new Mail Profile without deleting the old one.
You can set this up on a test machine before applying it to a user.

Navigate to:
-Control Panel
-User Accounts/Mail
-(Click on Show Profiles)
-Add a Profile (Choose a Unique name)
-Set this profile to the same e-mail address as the trouble user
-Once the setup for the Mail Account is done make sure the correct Account is selected on "Always Use This Profile"

If the name search doesn't work from that newly setup account then there is a problem with the Exchange Server settings.
0
 

Author Comment

by:casscar
ID: 41881652
Already tried this but it worked for around 15 minutes until the cache downloaded all the email, contacts etc. and then the issue came back.
0
 
LVL 3

Expert Comment

by:Adiel de Freitas
ID: 41882295
In Outlook have you emptied the Auto-Complete List?

-File
-Options
-Mail
-Send Messages
-(Empty auto-Complete List)
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 6

Expert Comment

by:Niten Kumar
ID: 41883712
Best solution in your case would be to setup GAL as default using GPO.  Check the following thread on how to set the GAL as default using GPO.

https://social.technet.microsoft.com/Forums/office/en-US/6bb9b40f-b794-41ce-93b4-711e77c53607/gal-default-adress-book-gpo
0
 

Accepted Solution

by:
casscar earned 0 total points
ID: 41886244
Hi All,

Thank you for your contributions issue has been resolved. The solution has been to download the Global Address List Locally.

Once Global Address List is downloaded locally it will start defaulting to it.

As mentioned earlier issue only occurs on users who use Outlook Cached Mode Enabled. Therefore it does make sense that the software would prefer to use a local address book over the Global Address book just in case it is not connected to the internal network.

By downloading the Global Address List locally it will then start using it as the default as it is set up to prefer the Global Address List.
0
 

Author Closing Comment

by:casscar
ID: 41894071
It is the only solution that worked.

The other solutions where tested but to no avail.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Changing a few Outlook Options can help keep you organized!
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses
Course of the Month9 days, 13 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question