Auto channel for WiFi (Access Point)

Hi All,

In my office, the building has 4 floors. With 10 APs, distance between APs about 7-15 meters, using the OpenWRT firmware with the setting parameter "auto" and I detected the channel of APs:
+ 4 APs the same channel (channel 5)
+ 3 APs the same channel (channel 1)
+ Rest of APs channel: 3, 6, 11

I also look for the automatically setting parameters to configure for this issue (don't use manual), please give me how to solve it.

Thanks in advance,
Who is Participating?
masnrockConnect With a Mentor Commented:
The nonoverlapping channels are 1, 6, and 11. The trick is to not have any two "adjacent" APS using the same channel. And to have any 2 APS using the same channel as far apart as possible.

I highly recommend doing a properly wireless survey. Might be good to see if you happen to have too many APs in use for your space.
weifaiConnect With a Mentor Commented:
Those that are on the same channel, are they close to each other? If not quite, then it's little of a problem.

But, in general, you should do some planning of channel assignments and assign them manually for each AP; close APs should have channels as far as possible from each other.
Also, you might have to look at the transmit power settings on each AP in order to take away interference issues.  Won't be surprised if you had to actually lower the transmit power on the bulk of your APs.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.