Solved

Server 2012 R2 Failover Cluster - Can't change network state to Do Not Allow...

Posted on 2016-11-10
5
101 Views
Last Modified: 2016-12-28
Hello,
I have three Exchange 2013 CU11 DAG's that are using Failover Cluster Services on Windows Server 2012 R2 machines.
By default the ISCI connections on all of them are supposed to be set to: Do not allow cluster network communications on this network.
However all of them are set to: Allow cluster communications on this network.
When I click the checkbox for "Do not..." and click apply it changes the state for about 20 seconds and then reverts back to "Allow..."

Please advise if you are familiar with this scenario.
Thanks,

j
0
Comment
Question by:Jeffrey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 18

Expert Comment

by:LesterClayton
ID: 41883445
Select the top node of the cluster - and expand the Server Name under the Cluster Core Resources.  Is the IP Address listed there on the same subnet as the iSCSI adapters?

Cluster-IP-Address.png
Check out the networks for your cluster.  Can you confirm that you have multiple cluster networks and that all of them have the status of "Up"?  Failover Clustering won't allow you to remove Cluster Communication from a network if Cluster Communication is not enabled on any other network, or any of the other networks is in a status of "Down".

Cluster-Networks.png
0
 

Author Comment

by:Jeffrey
ID: 41884014
LVL 17, thank you for the response and information.

The cluster subnet is different than both ISCI subnets. Each node has a different subnet for MAPI, Replication and 2 ISCSI connections back to the storage array. All are enabled and up.

NIC's
(2) ISCSI = Cluster Only (weird, the cluster service is supposed to set this to "no comm..." automatically when building the cluster
(1) Repl = Cluster Only
(1) MAPI = Cluster & Client Communication
0
 
LVL 18

Expert Comment

by:LesterClayton
ID: 41886085
I've run out of ideas :)  Sorry.  I don't even have an iSCSI solution anymore with which to test - everything I have is FC.
0
 
LVL 14

Accepted Solution

by:
Schnell Solutions earned 500 total points
ID: 41888322
Here is how you should proceed...

1. Validate the current configuration using the EMS:
Get-DatabaseAvailabilityGroupNetwork
(Pay attention to the values: MapiAccessEnabled, ReplicationEnabled,IgnoreNetwork)

2. Try changing the configuration through the EMS: (Read the below details about the meanings of each parameter)
Set-DatabaseAvailabilityGroupNetwork  <YouriSCSI-NetworkName>  -ReplicationEnabled $False
Set-DatabaseAvailabilityGroupNetwork  <YouriSCSI-NetworkName>  -IgnoreNetwork $False

ReplicationEnabled: specifies whether the network can be used for replication activity. If this parameter isn't specified, the default behavior is to enable the network for replication.

IgnoreNetwork: indicates that the specified network should be ignored and not used by the DAG. Any network that is Ignored results in a state of disabled regardless of the other settings.

The third option is not controlled by Exchange commands, but from the NIC settings. It means that the setting MapiAccessEnabled is actually determined by the settings of the network adapter on the local server.  A network is MapiAccessEnabled when we detect that the “Resgister this connection’s address in DNS” checkbox is enabled on the advanced TCP properties of the network adapter. If you want to disable it, go to the properties of your network adapter and clear the check box that allows your NIC to register in the DNS server.

It is normal that if we just use the Failover Cluster Manager on a server that is a member of a DAG, it will result in the change being reverted. Heheheh, sounds a bit bizarre, but it is how it works.
1
 

Author Closing Comment

by:Jeffrey
ID: 41888961
Thanks for the help! I need to remember that the GUI does not always give the expected results. I used the commends that you listed and they removed the ISCI connections from all communication as they are supposed to. Thanks again!
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question