Solved

Exchange 2013 - unable to recieve external emails

Posted on 2016-11-11
14
34 Views
Last Modified: 2016-11-17
Hi Experts, have an issue where we are unable to recieve any external email. We had an existing email server and we added a new Exchange server. All URLs match for both servers and so do the certs. Today we made a change to firewall and externals DNS since IP address of new Exchange server has changed and now we are not receiving any external emails

Internal emails and sending emails to external domains is working fine

TIA
0
Comment
Question by:abhijitm00
  • 7
  • 6
14 Comments
 
LVL 14

Expert Comment

by:Jason Crawford
Comment Utility
Where is the current MX record pointing?
0
 

Author Comment

by:abhijitm00
Comment Utility
MX record points to Comodo Antispam gateway so there is no change there
0
 
LVL 14

Expert Comment

by:Jason Crawford
Comment Utility
Have you tried running a message trace on the Comodo?  It would be helpful to know if it's ever received by an Exchange server or if it dies at the gateway.

What server is the Comodo handing off to?
0
 

Author Comment

by:abhijitm00
Comment Utility
I am getting: Relay : exchange.domain.org:25
 Error code : 500
 Error message : SMTP host unreachable
 No entries on your request
0
 
LVL 14

Expert Comment

by:Jason Crawford
Comment Utility
Ok did you add a firewall ACL and NAT for the Comodo IP on port 25?
0
 

Author Comment

by:abhijitm00
Comment Utility
No there is no ACL for Comodo on the firewall. It is open to all IPs
0
 

Author Comment

by:abhijitm00
Comment Utility
Just want to recap - Existing server name - mail.domain.org. All URLs point to mail.domain.org on both Exchange servers. New server name is exchange.domain.org. But cert has mail.domain.org as primary and exchange.domain.org and autodiscover as SANs.

All external DNS for autodiscover, mail.domain.org (via CNAME) point to exchange.domain.org which has a new external IP. NAT to old server mail.domain.org is stopped. At this time Activesync, Autodiscover and Outlook Anywhere stop working. Sending emails externally and internally work so does recieving emails internally, what does not work is emails sent from outside.

Would this have anything to do with FQDN name on recieve connectors or SSL certs?
0
Want to promote your upcoming event?

Is your company attending an event or exhibiting at a trade show soon? Are you speaking at a conference? Spread the word by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

 

Author Comment

by:abhijitm00
Comment Utility
Also wanted to add to comment above that Comodo Antispam can't seem to connect to exchange.domain.org on port 25 although all firewall rules seem fine
0
 
LVL 14

Assisted Solution

by:Jason Crawford
Jason Crawford earned 500 total points
Comment Utility
In that case you should be able to test access through the firewall by going to canyouseeme.org while logged on to the server receiving email from the Comodo and specify port 25.  Either that or you can try sending an email with PowerShell while off the network:

Send-MailMessage -From sender@domain.com -To recipient@domain.com -SmtpServer exchange.domain.com -Subject 'Testing' -Body 'This is a test'

Open in new window


If your firewall truly accepts all connections on port 25 that should at least make it to a Receive Connector.  While you're at it you should enable verbose logging on all Receive Connectors:

https://msdn.microsoft.com/en-us/library/bb124531(v=exchg.160).aspx
0
 

Author Comment

by:abhijitm00
Comment Utility
Ok made some firewall changes and email is indeed flowing to new Exchange server.

Autodiscover and Outlook Anywhere is connecting but only after creating a new profile by manually adding server name. I have changed all URLs to point to exchange.domain.org and removed mail.domain.org from external DNS.
0
 
LVL 1

Expert Comment

by:MB Shaikh
Comment Utility
Hi,

Once if you receive you external email at your Comodo Antispam gateway, then check your newly installed exchange server is accepting connections on port 25 from  Comodo Antispam gateway  vice versa  probably fire wall may be enabled on newly installed exchange server and in Comodo Antispam gateway you allow proper routing etc.

regards,
MB Shaikh.
0
 

Author Comment

by:abhijitm00
Comment Utility
Android and iPhones are not able to configure using autodiscover. If I manually setup profile using server name I am able to connect. Outlook anywhere is working correctly. How can I fix autodiscover for phones? Currently i have autodiscover A record pointing to external IP of exchange.domain.org. There is also a _srv autodiscover record pointing to website, should i change this to exchange.domain.org?
0
 
LVL 14

Accepted Solution

by:
Jason Crawford earned 500 total points
Comment Utility
Yes you only need public DNS record for Autodiscover.  The A record you currently have in place should be fine so remove the SRV.
0
 
LVL 14

Expert Comment

by:Jason Crawford
Comment Utility
Glad I could help.  Take care :)
1

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Join & Write a Comment

Suggested Solutions

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now