Sharepoint 2013 An exception occurred when trying to issue security token

cant access central admin or any site

event id 8306 : Sharepoint foundatition, Claims authentication
An exception occurred when trying to issue security token: Loading this assembly would produce a different grant set from other instances. (Exception from HRESULT: 0x80131401).



Application: w3wp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
Stack:

Server stack trace:
   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)




An unhandled exception occurred and the process was terminated.

Application ID: /LM/W3SVC/922178507/ROOT

Process ID: 15328

Exception: System.IO.FileLoadException

Message: Loading this assembly would produce a different grant set from other instances. (Exception from HRESULT: 0x80131401)

StackTrace:
Server stack trace:
   at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
oompaloompaAsked:
Who is Participating?
 
oompaloompaConnect With a Mentor Author Commented:
there were missing registry keys, maybe from some .NET update ?

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework’, create a new ‘DWORD (32-bit) Value’ named "LoaderOptimization" with a value .

‘HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework‘, create a new ‘DWORD (32-bit) Value’ named "LoaderOptimization" with a value 1.
3
 
Walter CurtisSharePoint AEDCommented:
Here is one thing to check that might help - make sure the IIS App Pool is running a user that has access to SharePoint and SQL.

Hope that helps...
0
 
oompaloompaAuthor Commented:
yes, it has access to sql, and that is verified

this is not new installation, it stopped working after restart
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
oompaloompaAuthor Commented:
found this https://blogs.technet.microsoft.com/sykhad-msft/2012/02/24/sharepoint-2010-nailing-the-error-the-security-token-service-is-unavailable/
trying to reprovision but stuck at $h.Provisioning() , it just stands here , how long should it take
0
 
Walter CurtisSharePoint AEDCommented:
I don't know exactly how long it will take, but it could be upwards of 15 minutes or so, depending upon the type of system it is running on. The article looks very good though.

...
0
 
oompaloompaAuthor Commented:
nothing, went thru the article , recreated services  and still cant access sites.
http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc works fine
0
 
Walter CurtisSharePoint AEDCommented:
Usually after a restart the service account can be an issue. I know you said it works fine access SQL, but check the account anyway in AD to make sure it is not now disabled or the password has expired. I know, it is set to never expire and the account is enabled, but never hurts to check I suppose. It has bitten me before.

Good luck...
0
 
GAURAV SINGHSenior SpecialistCommented:
Can you share the result what happens when you browse central admin site from IIS directly?
Try to re-enter the password under the identity section of the site for the account which is running the site application pool.
Do an iisreset and let me know the outcome.
0
 
oompaloompaAuthor Commented:
For ca i get 404, for created site i get error 500, i did entwr credentials again, accounts are not locked and password are ok
0
 
Walter CurtisSharePoint AEDCommented:
Glad you got it fixed. The updated made changes, but they didn't kick in until the restart. Been there, done that. Don't you hate it when that happens!

Good find...
0
 
oompaloompaAuthor Commented:
resolved with MS support
0
All Courses

From novice to tech pro — start learning today.