Remote shutdown Windows 10

I have 2 Windows 10 PCs and I want to shutdown one from the other. I have tried the command print methods but keep getting rejected by remote PC
mortonkrAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
mortonkrConnect With a Mentor Author Commented:
I found there is a registry edit that needs to occur. This fixed it. See file attached.
Registry Edit
0
 
Cliff GaliherCommented:
All windows remote shutdown methods do the same thing. They use WMI under the covers. So whether the old command-prompt, PowerShell, or GUI, all send the exact same network packets. If it is failing then no other method will suddenly work. You have to solve the underlying problem. DNS, firewall blocking WMI, or account permissions.
0
 
JohnBusiness Consultant (Owner)Commented:
When you Shutdown /r (/f) /m  \\computername from an admin command prompt, what error do you get?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
mortonkrAuthor Commented:
I get Access is denied.(5)
I have the the same user on both PC's and that user is member of the admin group
It worked once only and each time after that i get this error!
0
 
JohnBusiness Consultant (Owner)Commented:
That error means a basic connection issue. The main system is not even seeing the other device. Make sure Network Discovery and File Print sharing are both ON, Home Group is OFF, and the firewalls are set to allow the other devices
0
 
mortonkrAuthor Commented:
I can ping the other pc name. F&P sharing is enabled, not sure how to disable home groups. I just set both systems to use users rather than homegroups
0
 
JohnBusiness Consultant (Owner)Commented:
The last change should disable Home Group. Is Network Discovery ON? And check Firewall Settings.

How are you handling Remote? Directly across the Internet or via VPN?
0
 
mortonkrAuthor Commented:
both pc's are on a LAN.
What firewall setting should I look for?
Its weird that it allowed me to do it once and not again!
0
 
JohnBusiness Consultant (Owner)Commented:
If the LAN's are connected over the Internet you need to permit the external addresses
0
 
mortonkrAuthor Commented:
They are on a local lan. not internet involved.
0
 
JohnBusiness Consultant (Owner)Commented:
Strange. Try from another machine on the same LAN
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Temporarily - to test if it's a firewall issue, disable the firewall on the target system.

Then, when specifying the shutdown, you must establish or have a pre-established session to the machine, I believe with admin rights.

Try the following sequence of commands:
NET USE \\remotePCNameOrIP /user:remotePCNameOrIP\localAccountWithAdminRights *
<you'll be prompted for that account's password; enter it>
SHUTDOWN -t 1 /m \\remotePCNameOrIP

(-t 1 has the same effect as -f but should be faster - it's the time to wait before shutdown in seconds)
0
 
McKnifeCommented:
Scrolling through the comments I expected that solution to come up (even although you said it worked without once ;-) ).
These are local users. Local admin users' tokens get filtered, that's how UAC works, even when working from remote.
0
 
mortonkrAuthor Commented:
I found a solution that worked
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.