Solved

Switching from Exchange 2007 on a domain, to Microsoft's Hosted Exchange service

Posted on 2016-11-18
3
62 Views
Last Modified: 2016-11-27
I'm waiting for a call-back from Microsoft support, but thought I might as well ask it here...

I have a client (who has a local domain) who just today switched to Hosted Exchange (office 365).  The DNS changes have been made and the switch works.

The new Hosted Exchange accounts have a new password of course, because the accounts were just set up today.

The problem is with the computers on the client's domain, say, abcd.local

I exported each user's Exchange mail to a PST file.  Then on the first machine I opened up Mail in Control Panel and created a new exchange profile.  In it I specified their email address and their new password (not their domain logon password).  It instantly responded with a message that the account was successfully set up.

Here's what I expected to see: Outlook connects to the new Microsoft server, and presents a fresh set of folders with basically no email.  I would then import their old PST into these folders.

Here's what I actually saw: All old folders were instantly there, including user-created ones, and little by little they populated with the old email.  However, when I log onto their OWA account online, no emails are there.  I went back to the Mail setup, and it confirmed that even though I put in the email address and *new* password, it said it was connected to "server.local".

I know that obviously I have to shut off Exchange services on the server (at least that makes sense to me), but the Microsoft tech who spoke briefly to me said, "Oh, you're on a domain? Well we need to do such-and-such.  I couldn't quite make out what he said, but when I said, "I assume I have to turn off Exchange Server services?" he said no. He's calling back, hopefully soon.

Is anyone familiar with my situation here, where I'm switching from on-domain Exchange 2007, and moving to Microsoft Hosted Exchange?
0
Comment
Question by:DaveWWW
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 41894101
After migrating, you should disable the Exchange Mailbox for each user otherwise Outlook will look locally for the mailbox and your server will tell Outlook that it looks after the mail and serve up your local Exchange Mailbox to Outlook, then disable the Autodiscover service locally so that Outlook uses DNS to find where the mail host is and that should sort your problems.

Disabling the mailboxes can be done via the Exchange Management Console and disabling Autodiscover via the Exchange Management Shell:

get-autodiscovervirtualdirectory | remove-autodiscovervirtualdirectory

That should remove the Autodiscover virtual directory

A blog for step by step in case you want extra guidance:

http://www.vspbreda.nl/nl/exchange/o365-remove-internal-autodiscover-when-moving-to-office-365-solved/

You would have been better to perform a migration to 365 via the 365 portal and let that suck in all your exchange data because you'll also have problems replying to existing emails from internal users because certain attributes haven't been copied across.

If you ant to fix that problem, you'll have to manually add the X400 / X500 address into 365 that correspond to the settings on your Exchange server and that will resolve that issue for you.

Alan
0
 

Accepted Solution

by:
DaveWWW earned 0 total points
ID: 41896132
Thank you Alan.  Actually I was able to circumvent the problem by implementing 3 registry settings that I found in a couple of articles online.  It involves going into Regedit to HCKU\Software\Microsoft\12.0\Outlook\Autodiscover and making these 3 Dword entries:
ExcludeScpLookup, value=1
ExcludeSrvLookup, value=1
ExcludeSrvRecord, Value=1

Once I logged off/on, I was able to set up a new Outlook profile, and it looked at Office 365 for the server info. I rasn Outlook, received waiting email, then imported the PST of old emails. Everything seems fine right now.
1
 

Author Closing Comment

by:DaveWWW
ID: 41902978
The info that Alan provided is excellent - however I was able to fix my specific issue with the registry entries noted. For other reasons, I wanted to keep the on-site Exchange Server running in the short term.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
Changing a few Outlook Options can help keep you organized!
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question