Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2016, moving a mailbox after suspending the move

Posted on 2016-11-18
2
Medium Priority
?
103 Views
Last Modified: 2016-11-18
I am in the process of replacing Exchange 2010 on one server with 2016 on another.  It is generally going well except for one issue.

I used EAC to move the mailboxes from the old database to the new one and have a problem.  The first time I attempted the move, it failed because the original server was offline.  It had failed on the first mailbox before I brought the original Exchange back online.  Once that was done, the others synced properly.

Because of a prompt that I saw, I used the shell to suspend the move of the failed account.  I believe that the command that I used was:
Suspend-MoveRequest -identity "email address here"

The batch finished properly with all but the first account moved.

Since then I've tried to move it with EAC but I've been unsuccessful each time.  I can select the one account and go through the steps, but nothing gets moved.  If I look at the details of the batch I see "0 selected of 0 total" at the bottom and "There are no items to show in this view" in the table.  It looks as if I failed to select the email account to move.

Of course, I COULD have made that mistake the first time; I've done worse before!  I was VERY careful the second and third time that I initiated a move and got similar results.

I tried issuing:
Resume-MoveRequest -identity "email address here"
thinking that it may have flagged my address as one not to be moved.  I get an error with that it "Couldn't find a move request...".  That makes sense to me as the request was cancelled.

What do I need to do to get the last mail account moved?
0
Comment
Question by:CompProbSolv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 
LVL 22

Accepted Solution

by:
CompProbSolv earned 0 total points
ID: 41893779
I believe I found the resolution and will post it here in case it helps anyone else.

There are a number of suggestions here:
https://social.technet.microsoft.com/Forums/office/en-US/e51ea278-543f-4363-ab16-c0529f442b65/mailbox-migration-reports-it-completed-ecp-shows-0-mailboxes-have-moved-and-the-mailbox-does-not?forum=exchangesvradmin

The one that did the trick for me is almost at the end.

I did:
Get-MigrationUser

 to see the list of users (just as confirmation) and noted that the one was listed as "Failed".  I then did:
Remove-MIgrationUser "email address I'm trying to remove"

That cleared it and allowed me to request again.

It failed the next time, but that is because of exceeding the quota.  That should be easy to fix.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 41893798
I fixed the quota problem and it is now syncing.

I don't think it was the Suspend command that got me in trouble.  It appears that after a failed migration batch you need to do the Remove-MigrationUser on the specific mailbox.  The link provides a command to remove ALL of them:

Get-MigrationUser | Remove-MigrationUser -force

I hope this helps someone!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question