How to successfully connect AWS EC2 with WS_FTP using SFTP/SSH

Hi. I'm trying to get WS_FTP Pro 12.5.1 to connect to my AWS EC2 instance using SFTP/SSH. No matter what I try, it fails to get through.

I have a key pair on AWS for this instance (generated by AWS) and its location on my Windows 7 Pro desktop, my username and pw (to access my instance via the FF browser), the host name, and the port has to be 22. I have the public key, but WS_FTP doesn't ask for this; instead it asks for the SSH key pair name which I selected.

Having entered these it connects to the host:
Connecting to [ip address]:22
Waiting for Server Response
Server Welcome: SSH-2.0-OpenSSH_6.6.1
Client Version: SSH-2.0-WS_FTP-12.5.1-0
RSA Signature Verified
Session Keys Created
Ciphers Created
New Client->Server ciphers in place
Completed SSH Key Exchange.  New Keys in place
Trying authentication method: "publickey"
 Server rejected public key
Failed SSH User Authentication
SSH Transport closed

Clearly, AWS rejected the public key.

Any ideas as to what I did wrong and how to correct this?
Torquil BeavisBusinessAsked:
Who is Participating?
 
serialbandConnect With a Mentor Commented:
Your WS_FTP looks like it's rejecting your key.  Did you put the correct key on the remote AWS server?  Have you tested SSH connections first?  Do you have PuTTY?  Connect to it with PuTTY and see if it works first.

https://docs.ipswitch.com/ws_ftp_server7/help/7745.htm
0
 
JohnBusiness Consultant (Owner)Commented:
In the Site setup, look at the active / passive flag.  You may need to set it to Active.
0
 
Torquil BeavisBusinessAuthor Commented:
Where in WS_FTP is the Site setup showing active/passive?
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
JohnBusiness Consultant (Owner)Commented:
See below from my own WS_FTP 12.5.1.

WS_FTP-Setup
0
 
Torquil BeavisBusinessAuthor Commented:
True in FTP, but SSH blanks this option out.
0
 
Torquil BeavisBusinessAuthor Commented:
Maybe I'm wrong but I believe AWS needs SFTP/SSH which is the one I'm using here
0
 
JohnBusiness Consultant (Owner)Commented:
SSH is a secure transfer so the mode is likely Passive. You need to check the firewall settings to make sure the traffic on port 22 can get through and communicate in both directions.
0
 
Torquil BeavisBusinessAuthor Commented:
In WS_FTP->Options->Firewall->New/Edit, I kept 'Use UPnP for PORT commands' blank, 'Force PORT IP address' blank, 'Limit local port range' blank, then configured a firewall:
Hostname, UserID, and PW as in SFTP/SSH setup
Type: [internal] SITE hostname (I don't know what this means)
Port: 22

Fails as before. Any ideas?
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
You have license for WS_FTP so I would, at this point, contact WS_FTP Support and AWS Support. I cannot figure out what is blocking you but they might know.
0
 
Torquil BeavisBusinessAuthor Commented:
Any other ideas, anyone?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.