Unable to install Kodi on Ubuntu Mate 15.04 because of unmet dependency 'curl'

I was trying to install the streaming app Kodi on Ubuntu Mate 15.04, based on these directions:

http://kodi.wiki/view/HOW-TO:Install_Kodi_for_Linux

I was unable to do it, because of an unmet dependency  'curl':

user@user-desktop:~$ sudo apt-get install software-properties-common
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
software-properties-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
user@user-desktop:~$ sudo add-apt-repository ppa:team-xbmc/ppa
 
 More info: https://launchpad.net/~team-xbmc/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp0pg395vb/secring.gpg' created
gpg: keyring `/tmp/tmp0pg395vb/pubring.gpg' created
gpg: requesting key 91E7EE5E from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp0pg395vb/trustdb.gpg: trustdb created
gpg: key 91E7EE5E: public key "Launchpad PPA for XBMC for Linux" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
user@user-desktop:~$ 
user@user-desktop:~$ sudo apt-get update
Hit http://us.archive.ubuntu.com vivid InRelease
Hit http://ppa.launchpad.net vivid InRelease    
Hit http://us.archive.ubuntu.com vivid/main Sources                    
Hit http://us.archive.ubuntu.com vivid/restricted Sources   
Hit http://ppa.launchpad.net vivid InRelease                
Hit http://us.archive.ubuntu.com vivid/universe Sources                        
Hit http://us.archive.ubuntu.com vivid/multiverse Sources         
Get:1 http://ppa.launchpad.net vivid InRelease [15.4 kB]          
Hit http://us.archive.ubuntu.com vivid/main amd64 Packages                
Hit http://us.archive.ubuntu.com vivid/restricted amd64 Packages          
Hit http://us.archive.ubuntu.com vivid/universe amd64 Packages                 
Hit http://us.archive.ubuntu.com vivid/multiverse amd64 Packages  
Hit http://ppa.launchpad.net vivid/main amd64 Packages
Hit http://us.archive.ubuntu.com vivid/main i386 Packages         
Hit http://us.archive.ubuntu.com vivid/restricted i386 Packages   
Hit http://ppa.launchpad.net vivid/main i386 Packages
Hit http://us.archive.ubuntu.com vivid/universe i386 Packages     
Hit http://us.archive.ubuntu.com vivid/multiverse i386 Packages   
Hit http://ppa.launchpad.net vivid/main Translation-en
Hit http://us.archive.ubuntu.com vivid/main Translation-en        
Hit http://us.archive.ubuntu.com vivid/multiverse Translation-en  
Hit http://ppa.launchpad.net vivid/main amd64 Packages
Hit http://us.archive.ubuntu.com vivid/restricted Translation-en
Hit http://us.archive.ubuntu.com vivid/universe Translation-en
Hit http://ppa.launchpad.net vivid/main i386 Packages
Hit http://ppa.launchpad.net vivid/main Translation-en
Get:2 http://ppa.launchpad.net vivid/main amd64 Packages [21.9 kB]
Get:3 http://ppa.launchpad.net vivid/main i386 Packages [21.8 kB]  
Get:4 http://ppa.launchpad.net vivid/main Translation-en [8,391 B]   
Fetched 67.5 kB in 8s (8,382 B/s)                                              
Reading package lists... Done
user@user-desktop:~$ 
user@user-desktop:~$ 
user@user-desktop:~$ sudo apt-get install kodi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kodi : Depends: curl
E: Unable to correct problems, you have held broken packages.
user@user-desktop:~$ 

Open in new window


When I try to install curl, I get more unmet dependencies:
user@user-desktop:~$ sudo apt-get install curl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 curl : Depends: libcurl3 (= 7.38.0-3ubuntu2) but 7.38.0-3ubuntu2.3 is to be installed
E: Unable to correct problems, you have held broken packages.
user@user-desktop:~$ 

Open in new window


What is happening here, and how can I correct it?

Thanks for your help.
AttilaBAsked:
Who is Participating?
 
MazdajaiConnect With a Mentor Commented:
Mirrors are the "repository" that you are attempting to download the updates. Can you try the following?
sudo apt-get update

Open in new window


Please post the following if it fails as you may need to update the mirrors:
cat /etc/apt/sources.list

Open in new window


It appears this is a known issue for libcurl in Ubuntu 15. Ubuntu is on a short life recycle, I also recommend updating it to 16 or 18.
https://www.ubuntu.com/info/release-end-of-life
0
 
MazdajaiCommented:
Can you post the mirrors your are using?
0
 
AttilaBAuthor Commented:
I don't understand the question. As you see in the captures from terminal I was just following the install instructions in the link, I am not sure what mirrors you are talking about.

Is there anything else I need to do, other then the command line instructions?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AttilaBAuthor Commented:
Actually the reason I have Ubuntu 15.05 on this machine is, that there was no way on earth to access wi-fi
with this installed hardware using Ubuntu 16.04. I have no idea why, but Ubuntu 16 seems to be extremely picky on
what kind of wireless network adapter it will work with. I had to replace mine in my desktop to make it work. But I don't have this luxury with this very small computer.  It worked though 'out of the box' with this, with Ubuntu 15.04, so I was happy.

If I upgrade the installation perhaps, instead of a fresh install is there a chance I can still keep the wi-fi working?

I will do
cat /etc/apt/sources.list

Open in new window

for you when I get home today.
0
 
MazdajaiCommented:
Please see my previous post and run
sudo apt-get update

Open in new window

first. It shouldn't break the wifi.
0
 
AttilaBAuthor Commented:
Probably first I should try something like:
sudo apt-get install make

Open in new window

or possibly:
sudo apt-get install --reinstall make

Open in new window

I will tell you how it works.
0
 
AttilaBAuthor Commented:
Well, I guess that's the real solution: Updating to Ubuntu 16. Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.