No Auto-Correction for Local Words on iOS 10.1

hi iOS folks

Is there anyone who noticed that after upgrading to iOS 10.1, all existing local auto-correction and auto-prediction are gone?

For example, with iOS 9, the iPhone could recognise something like Coles, Woolworth (two famous Supermarkets in Australia, like Walmart in the US), then automatically correct the word if it was incorrectly spelled or no upper case for the first letter.

How can I get the feature back?

Thanks,
bbao
LVL 37
bbaoIT ConsultantAsked:
Who is Participating?
 
Eoin OSullivanConsultantCommented:
@bbao - I'm sure you don't need instructions on how to restart your iPhone.
If you have multiple keyboards configured the autocorrect settings are linked to each keyboard (language) so it is worth checking you're using the keyboard you used before upgrading as it could be as simple at that.

The auto-correct feature on iOS has evolved a little in the various releases but all the configuration can be done in the “Settings” app on the iPhone or iPad, go to “General” and then to “Keyboard”.  I've upgraded from iOS 9 to 10 and didn't lose my personal auto-correct spellings.

The iPhone SHOULD retain your auto-correct spellings between updates but is there any chance you reset the Keyboard Dictionary?
Settings > General > Reset > Reset Keyboard Dictionary .. as this will clear ALL your saved spellings on all keyboards and might explain why your previous auto-corrects are gone.

I'm sure you know how to SAVE custom spellings by typing in the DESIRED spelling .. then press the left-most autocorrect option which shows the word in Quotation Marks .. this tells iOS to save that specific spelling in its auto-correct library

The good news is that you can quickly add in your own shortcuts or spellings in the Settings > General > Keyboard > Text Replacement.  There are also tricks that if you add entries in the iOS Contacts or Notes which use your spellings then iOS can use them .. for example add a Contact for Woolworth or Coles as the Company name and put in a phone number or website .. now iOS will recognise that as a valid spelling.  I think this method also works with entries in the Notes.

The bad news is that you cannot see or edit any of the auto-correct spellings .. you can manually edit your own Text Replacements but all the rest are hidden .. so you have to RESET KEYBOARD DICTIONARY and start again if you have lots of unwanted or incorrect entries.
2
 
JohnBusiness Consultant (Owner)Commented:
Auto Correct works on my iPhone SE with IOS10.1.1. It works when I am posting here.

Make sure you have selected both American and Apple Dictionaries under General Settings (or Local if not American).
0
 
JohnBusiness Consultant (Owner)Commented:
Also, if you changed (or even if not), turn the phone all the way off (hold down the top button and swipe Power Off). Wait a minute and start it back up.
0
 
bbaoIT ConsultantAuthor Commented:
thanks for the suggestion. i do have mutilple keyboard, and yes the auto-correct settings are linked to each keyboard, but I had to scroll down further to see the related settings. Apple is so stingy to give any space for a permanent scroll bar!

the reason is I don't know why the related settings were off and now they are turned back to on, as shown below.

IMG_2793.PNG
but i notice one thing is different now: spelling check no longer corrects capitalisation error and leave it to Auto-Capitalisation. it might make sense but not something I need. i don't need Auto-Capitalisation to start a sentence with upper case but I do need to make sure proper nouns shown in a proper way, like "coles" to be shown as "Coles".

as I turned off Auto-Capitalisation, the iPhone no longer corrected me for Australian proper nouns.
0
 
bbaoIT ConsultantAuthor Commented:
working now! thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.