Your computer can't connect to the Remote Desktop Gateway Server

Internally there's no issue connecting. Externally, we can access RDWeb, but when launching the published RDP collection comes back with error after entering credentials - You're computer can't connect to the Remote Desktop Gateway Server. Please contact your network administrator. We have an existing RDS environment that is currently working, we are setting up a test environment on a new hardware.


Setup:

Server 2012 R2.
Fresh install, Single Server Deployment Setup for Proof of Concept. (GW, Host, Licensing etc. in one server)
Public Cert installed.
Different Public IP, Port Forwarding is correct

We pretty much copied the settings on the working RDS but for some reason this test environment is not working.
365techcaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Try resetting TCP/IP along with DNS Flush

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Also make sure that there is not an "always on" VPN connection in the way.
1
 
365techcaConnect With a Mentor Author Commented:
Thanks John, the flushing of DNS didn't exactly resolved the issue but your input kinda suggested that it might be related to network issue instead of my server configuration. I have updated my IP/network settings and it seems to be working now.
0
 
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help you resolve the issue
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.