Windows XP Task Scheduler - task wouldn't execute

Hello experts, I've never used the Task Scheduler before and recently tried to set up a task to launch a simple .cmd batch file at a specified time. It wound up not working because upon launch it asked for the password for the current user. On this old XP system I don't have any specific password that I use when I log in.. it just boots right up. Could it be that the password that the task scheduler is looking for is just the default "administrator", or something like that?

Thanks
   Shawn
shawn857Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
It runs fine on my Vista Business machine (Virtual Machine).

Start, Administrative Tools, and right click on Task Scheduler. Select Run as Administrator. Try that.

Vista-Task-Scheduler
0
 
John HurstBusiness Consultant (Owner)Commented:
Does "administrator" have a password?  It is not disabled in XP. If never set, password is blank and then Task Scheduler should work without a password.

Make sure the XP user you are using is a member of the Administrator's Group. Users and Groups.
0
 
shawn857Author Commented:
Thanks John... I went into USER ACCOUNTS and my user account "JD" says "Computer Administrator" next to it, so I guess it's administrator. There is no password set... there never has been. I went back in to the Task Scheduler to try and run my batch file again. I filled in everything as I had did before. When I finished the wizard, it popped up a window saying:

---------------------------
Task Scheduler
---------------------------
The new task has been created, but may not run because the account
information could not be set.
The specific error is:
0x80070005: Access is denied.
Try using the Task page Browse button to locate the application.
---------------------------
OK  
---------------------------

I clicked on that and waited the couple of minutes to see if it would launch... it failed. Gave a status of "Could not start".

Thanks
    Shawn

P.S: Wasn't there another comment by an expert on this question? I received an email saying there was a comment by "Pune Tech". I saw the comment and read it last night, but tonight it's gone.
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
John HurstBusiness Consultant (Owner)Commented:
Thanks for the clarification.

Try making a password for your user Account, restart and try again.

If that does not work, then it appears something has gone wrong with XP - that is, it is not purely a setup or permission issue.

If you have the XP Install CD, try running System File Checker.

You are and Administrator. Open cmd.exe with Run as Administrator and run SFC /SCANNOW. Allow to complete, restart and test.
0
 
shawn857Author Commented:
Well, I don't want to have to put in a password everytime I reboot this XP computer. I'm going to switch to my Vista desktop to try running this task instead. I just had a look at this page on how to setup Task Scheduler in Vista:

http://www.wikihow.com/Use-Task-Scheduler-(in-Vista)

Seems 10 times more complicated than XP but I got it set up and instructed it to launch my .cmd file in a few minutes. So I waited and when the launch time rolled around nothing happened. No message, no error, no change of status of my task in the Task Scheduler... nothing at all. Status still reads "ready". The user account ("Joan") on this computer is set up as Administrator also... no password.

So I'm stumped again...

Thanks
   Shawn
0
 
John HurstBusiness Consultant (Owner)Commented:
XP is generation passed DEAD. Passwords are now a fact of life, so best get used to it. The whole world (maybe except for you) uses passwords now.
0
 
shawn857Author Commented:
Be that as it may... can you help?

Thanks
   Shawn
0
 
John HurstBusiness Consultant (Owner)Commented:
I have only ever used passwords. If you try a password and that does not work and nothing else has worked, you may need to reinstall XP Pro.
0
 
shawn857Author Commented:
No John, as I mentioned a couple of messages ago - I switched to my Vista machine to try to make this work, but still not working. Can you help me there?

Shawn
0
 
BillDLCommented:
Problems with Task Scheduler not running *.CMD (batch) files properly is common.

What is the exact command that you have used to launch the CMD file?
Does it call CMD.EXE and run the *.CMD file as a parameter by specifying the fully qualified double-quoted path to it.

What does your batch file do?
Does it use environment variables like %USERPROFILE%
0
 
shawn857Author Commented:
OK I got it working on Vista guys! BillDL - thanks for your comment too, the batch file invokes a stock data downloading program to gather quotes from Yahoo Finance. What did the trick was putting a check mark next to "Run with highest privilege" in the PROPERTIES|GENERAL tab. Don't know why this was necessary as my user account was Administrator anyway, but oh well... as long as it works.
    My one last question is - in XP's basic Task Scheduler I could set this task to be run every WEEKDAY (no need for stock downloads on weekends, of course)... but in the Vista Task Scheduler - even with it's tons of options and settings - I don't see this anywhere. Any thoughts?

Thanks
    Shawn
0
 
BillDLConnect With a Mentor Commented:
Shawn, I have never owned a Vista computer.  I've fixed a few of them though.  I bypassed that OS completely and have a Windows 7 laptop, but my main computer still is .... ready for it ..... Windows XP - shock, horror !!!  Yes, this "dead in the water" PC has never been hacked or caught a virus and it does what I need it to do for the time being.  Some of us can't afford to buy new computers every time Microsoft rushes out another half-baked operating system, and I will use Linux before I buy Windows 10.

If Windows Vista is the same layout as the Windows 7 Task Scheduler, then as Jim Cofer states in his blog article, getting to the "Weekdays" option is counter-intuitive.  Under the Task Trigger you choose "Weekly" and you then see the days of the week checkboxes:
http://jimcofer.com/personal/2012/03/16/win7-task-scheduler-and-weekdays/
0
 
shawn857Author Commented:
That did the trick, thank you! Everything's good now!

Cheers
   Shawn
0
 
shawn857Author Commented:
That did the trick, thank you! Everything's good now!

Cheers
   Shawn
0
 
shawn857Author Commented:
Thanks gentlemen!

Shawn
0
 
John HurstBusiness Consultant (Owner)Commented:
You are welcome and I was happy to help.
0
 
BillDLCommented:
Thank you Shawn
0
All Courses

From novice to tech pro — start learning today.