Solved

SSH refused connection cisco switch

Posted on 2016-11-22
7
21 Views
Last Modified: 2016-11-22
Any idea why ssh will refuse connections?  I  ssh into the switch yesterday and today it's refused my connection.  I checked the backup config from yesterday and today no changes were made using net++.
0
Comment
Question by:fofanah78
  • 3
  • 2
  • 2
7 Comments
 
LVL 2

Expert Comment

by:Shark Attack
ID: 41897746
you need to verify the crypto key and ensure it's still there and generated. are you authenticating locally? do you have access to console?
0
 

Author Comment

by:fofanah78
ID: 41897750
Yes. Im consoled in @ the moment.
0
 
LVL 2

Expert Comment

by:Shark Attack
ID: 41897754
did you check for RSA key? If you dont have it create it.
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 27

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 41897779
Check are all available vty lines in use. Maybe previous ssh sessions were not closed properly, so there is no free vty lines.

#sh users
#sh ssh

If that is the problem you can disconnect sessions by using:
#disconnect ssh ?
  <0-903>  The number of the active SSH connection
  vty      Virtual terminal
  x/y      Slot/Port for Modems
0
 

Author Comment

by:fofanah78
ID: 41897845
@ jovic
What's the command to clear ssh on the router?
0
 
LVL 27

Expert Comment

by:Predrag Jovic
ID: 41897909
Basics are typically the same, however can depend on device type.

If that happens too often configure login timeout on device (had to do it on one device):
# line vty 0 15
# exec-timeout <minutes>

You can also use global configuration mode:
# ip ssh time-out <sec>      <-- (1 -120 sec)
should do the trick.

Or you can configure TCL on device to periodically clear vty lines (at least some of them).

Also manually clearing vty line should be possible to do with:
#disconnect ssh 5
or
# clear line vty <number>           <-----  Reset a terminal line
0
 
LVL 2

Expert Comment

by:Shark Attack
ID: 41897938
i doubt this was the issue. so you're saying all your ssh lines were taken hang up?
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now